Mautic Community Forums

Internal Server Error

Hi,

when I try to install Mautic ver. 2.8.2, this is a error message:



Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@abgest.it to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.



I’ve contacted my host and the answer is that ther’s a PHP crash with generic error:



[Thu Jun 29 13: 35: 12.842407 2017] [core: error] [pid 129672: tid 140313804752640] [client 46.28.1.44:54288] End of script output before headers: index.php, referer: http: // abgest. en / 2.8.2 / installer / step / 1




What can I do?



Regards.



Giancarlo

Hi,
when I try to install Mautic ver. 2.8.2, this is a error message:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@abgest.it to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

I’ve contacted my host and the answer is that ther’s a PHP crash with generic error:

[Thu Jun 29 13: 35: 12.842407 2017] [core: error] [pid 129672: tid 140313804752640] [client 46.28.1.44:54288] End of script output before headers: index.php, referer: http: // abgest. en / 2.8.2 / installer / step / 1

What can I do?

Regards.

Giancarlo

More info about your hosting (shared, VPS etc) i have helped a lot of people from Italy and most of the problem is the hosting providers don’t do their job.

WHAT phP vERSION ARE THERE ?

better you talk with your hosting provider to update PHP version on your server. This is a one and last solution for this kind of error.

500 Internal Server Error

  1. Thought it was an mautic .htaccess issue.
    As Wordpress’s .htacesss works fine on GoDaddy Ultimate Linux (shared) hosting (multiple sites).
    PHP version upgraded via GoDaddy control panel to v5.6 already.

  2. Thought it might be a permissions issues, due to unzipping mautic v2.11.0.zip locally and then FTPing up to server.
    So enabled SSH in the GoDaddy control panel
    and in the correct directory (set up via Hosted Domains in Control Panel) via Putty did a:
    wget https://s3.amazonaws.com/mautic/releases/2.11.0.zip
    unzip 2.11.0.zip

Correct Permissions already there:
files 644
dirs 755

and the files owner is my GoDaddy primary user and the same as Wordpress,.

  1. 500 Internal Server Error still persisted, no logs, no installation wizard.

  2. FIX: Edited .htaccess to the below

  3. FIX: and added a .user.ini to the mautic website’s directory then it worked !
    Note: changing the php.ini or php56.ini files does not work.

; mautic .user.ini
always_populate_raw_post_data = -1[/code]

[code]# mautic .htaccess
# Use the front controller as index file. It serves as a fallback solution when
# every other rewrite/redirect fails (e.g. in an aliased environment without
# mod_rewrite). Additionally, this reduces the matching process for the
# start page (path "/") because otherwise Apache will apply the rewriting rules
# to each configured DirectoryIndex file (e.g. index.php, index.html, index.pl).
# DirectoryIndex index.php

<IfModule mod_rewrite.c>
    RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

    # Set Authorization header for OAuth1a for when php is running under fcgi
    RewriteCond %{HTTP:Authorization} .+
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    # Determine the RewriteBase automatically and set it as environment variable.
    # If you are using Apache aliases to do mass virtual hosting or installed the
    # project in a subdirectory, the base path will be prepended to allow proper
    # resolution of the app.php file and to redirect to the correct URI. It will
    # work in environments without path prefix as well, providing a safe, one-size
    # fits all solution. But as you do not need it in this case, you can comment
    # the following 2 lines to eliminate the overhead.
    RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::2$
   RewriteRule ^(.*) - [E=BASE:%1]

    # Redirect to URI without front controller to prevent duplicate content
    # (with and without `/app.php`). Only do this redirect on the initial
    # rewrite by Apache and not on subsequent cycles. Otherwise we would get an
    # endless redirect loop (request -> rewrite to front controller ->
    # redirect -> request -> ...).
    # So in case you get a "too many redirects" error or you always get redirected
    # to the start page because your Apache does not expose the REDIRECT_STATUS
    # environment variable, you have 2 choices:
    # - disable this feature by commenting the following 2 lines or
    # - use Apache >= 2.3.9 and replace all L flags by END flags and remove the
    #   following RewriteCond (best solution)
  # RewriteCond %{ENV:REDIRECT_STATUS} ^$
  # RewriteRule ^index.php(/(.*)|$) %{ENV:BASE}/$2 [R=301,L]

    # If the requested filename exists, simply serve it.
    # We only want to let Apache serve files and not directories.
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule .? - [L]

    # Rewrite all other queries to the front controller.
    RewriteRule .? %{ENV:BASE}/index.php [L]
</IfModule>

<IfModule !mod_rewrite.c>
    <IfModule mod_alias.c>
        # When mod_rewrite is not available, we instruct a temporary redirect of
        # the start page to the front controller explicitly so that the website
        # and the generated links can still be used.
        RedirectMatch 302 ^(?!/(index.php|index_dev.php|app|addons|plugins|media|upgrade))(/(.*))$ /index.php$2
        # RedirectTemp cannot be used instead
    </IfModule>
</IfModule>

<IfModule mod_php5.c>
    # @link https://github.com/mautic/mautic/issues/1504
    php_value always_populate_raw_post_data -1
</IfModule>

<IfModule mod_deflate.c>
    <IfModule mod_filter.c>
        AddOutputFilterByType DEFLATE application/javascript
        AddOutputFilterByType DEFLATE application/rss+xml
        AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
        AddOutputFilterByType DEFLATE application/x-font
        AddOutputFilterByType DEFLATE application/x-font-opentype
        AddOutputFilterByType DEFLATE application/x-font-otf
        AddOutputFilterByType DEFLATE application/x-font-truetype
        AddOutputFilterByType DEFLATE application/x-font-ttf
        AddOutputFilterByType DEFLATE application/x-javascript
        AddOutputFilterByType DEFLATE font/opentype
        AddOutputFilterByType DEFLATE font/otf
        AddOutputFilterByType DEFLATE font/ttf
        AddOutputFilterByType DEFLATE image/svg+xml
        AddOutputFilterByType DEFLATE image/x-icon
        AddOutputFilterByType DEFLATE text/css
        AddOutputFilterByType DEFLATE text/javascript
        # Do not enable compression for file types that could contain secrets
        #AddOutputFilterByType DEFLATE text/html
        #AddOutputFilterByType DEFLATE text/plain
        #AddOutputFilterByType DEFLATE text/xml
        #AddOutputFilterByType DEFLATE application/xhtml+xml
        #AddOutputFilterByType DEFLATE application/xml
        #AddOutputFilterByType DEFLATE application/json
        <IfModule mod_setenvif.c>
            <IfModule mod_header.c>
                # Remove browser bugs (only needed for really old browsers)
                BrowserMatch ^Mozilla/4 gzip-only-text/html
                BrowserMatch ^Mozilla/4.0[678] no-gzip
                BrowserMatch bMSIE !no-gzip !gzip-only-text/html
                Header append Vary User-Agent
            </IfModule>
        </IfModule>
    </IfModule>
</IfModule>