Is there anyone who can help me checking fresh installation?

Your software
My Mautic version is: 5.0.3
My PHP version is: 8.0.30
My Database type and version is: pdo_mysql 5.7.23-23

Your problem
My problem is: Almost evryhthing!

Creating contact lists done.
Creating segments done.
Assigning contact to segments done.
Emails created.
Campagins created.
Test email successful

But here the problem begins:

  1. Campagins always shows NO CONTACT
  2. Campaign is published with NO CONTACT
  3. Instead of launchhing a campaign (due to NO CONTACT) I try sending email and it says “EMAIL SENT”, but in fact it doesn’t go anywhere.

I have never come across with such a difficulty so far. I spent alot of time to understand why, but im totally in the middle of nowhere! Is there any good heart to have a short look at my installation settings if anything is wrong?

These errors are showing in the log:

Steps I have tried to fix the problem:

1 Like

Have you set up the required cron jobs?

Yes, I did it in the campaign but at a very basic level: “send email”.

Are you sure you set up cronjobs? If so, can you copy them here?

Hello, “cronjobs” mean the tasks assigned at the campaign process, am I rgiht? As mentioned previously I assigned a basic level (one-step) task to the campaign as “send email”, and thats all. Is this wrong?

So I did the following:

  1. Imported contacts
  2. Created segments
  3. Assigned relevant contacts to relevant segments
  4. Created email
  5. Sent test mail - worked fine
  6. Created campaign
  7. Setup the cronjob for the campaign

What is missing here and why my campaigns always show NO CONTACT although it says campaign started?

I already gave up with the campaign but instead I tried Emailing without campaign, and it says “emails sent” to relevant contacs but its wrong, nobody didn’t receive any email.

Very much confused indeed!

Just in order to make sure if there was something wrong during the initial setup of the software, I created another subdomain and reinstalled a fresh Mautic, surely correct this time. However its still the same again. And by the way there is nothing wrong with smtp, dkim, dmarc, etc. settings of my email account.

@allingus I feel like not a lot of people have made the switch to 5.0.3 yet - I’d recommend to use 4.4.7 for production use still, as it is more reliable.

Here a screenshot of my cron jobs I am using in 5.0.3. E-Mails are working this way.

It took a while until it worked though.

sorry - most recent is 4.4.11 :wink:

1 Like

Thanks Peter. Where can I download 4.4.11?

Is there a logical explanation why it says SENT while it did not? What is the problem here?

I know it didn’t send because I was among the recepients and I didn’t receive it. Can someone please tell me why Mautic is not telling the truth?

Mautic did send it, but maybe your smtp didn’t dispatch it.
Here is how email sending works:

Helllo Joey, thanks. I forwarded the question to technical support department of Hostgator underlining if there is any communication problem that needs to be fixed between the SMTP and MAUTIC. They say everything seems to work normal but the issue is now escalated to admin level and they will come back to me soon.

here :wink:

Did you setup to queue mails?

No, but I shared this smtp dispatch problem with Hostgator and they whitelisted my account. Upon this confirmation I gave another try and this time (for the first time) Mautic started sending emails but immediately started a queue. Now its been some 3 hours but I don’t know what to do with this queue and I didn’t do any setup with it. :frowning:

Could you please tell me what to know or what to do in queue settings? I just copied basics of the Email Settings but Im not sure if I did the right thing…

20 hours passed still in the queue… :frowning:

What PHP version should I use with this 4.4.11?