Issues with drag and drop of the new Editor

Your software
My Mautic version is: 4.1.1
My PHP version is: 7.4
My Database type and version is: MariaDB 8.0.27

Your problem
My problem is:
When I create a new Landing Page or E-Mail with either the blank or any MJML templates, I can edit text, change colors etc. but I cannot drag and drop any elements from the right side panel onto the canvas.

These errors are showing in the log:
None in var/logs/mautic_prod-2022-01-18.php and
none in the /var/logs/apache/error.log
In the console window, I can just see a warning: “beautify” option is deprecated in mjml-core and only available in mjml cli.

Steps I have tried to fix the problem:
Tried both editor
Checked in the DB whether pages table contains data inside custom_html

It’s a brand new installation (no upgrade).
On localhost (without https)

Further error:
Sometimes, I get this error in the console:
index.js:437 Uncaught TypeError: Cannot read properties of undefined (reading ‘width’)
at Object.getTargetToElementFixed (index.js:437:32)
at r.updateToolsGlobal (SelectComponent.js:675:33)
at r.updateGlobalPos (SelectComponent.js:203:10)
at r.onFrameUpdated (SelectComponent.js:146:10)
at Zt (_executeBound.js:8:65)
at bind.js:10:12
at restArguments.js:16:27
But not when I drag & drop anything.

In the screenshot you can see that I can drag the elements, but I can’t drop them.