Mautic Community Forums

Landing Page URL Error

Hi,



I installed Mautic into a folder just into the WWW document root. I think, the application (e.g. the campaigns) should be accessible via

Code:
http://.../mautic/s/campaigns/view/5

but that does not work. I have to make the URL look like
Code:
http://.../mautic/index.php/s/campaigns/view/5

to be able to use the application.

That would not be a real issue but it becomes one when I get to the landing page functionality. When I create a landing page and insert it into an email, the generated link looks like
Code:
http://.../mautic/landing-page-part?ct=...tracking...code...

This URL generates a 404, because the application expects the .../index.php/... part which is there when I work with the frontend but is missing in the generated landing page URL.

My very limited technical skills tell me that something is wrong with the URL rewrite - maybe it is not. :-)

Any ideas?

Peter

Hi,

I installed Mautic into a folder just into the WWW document root. I think, the application (e.g. the campaigns) should be accessible via

http://.../mautic/s/campaigns/view/5

but that does not work. I have to make the URL look like

http://.../mautic/index.php/s/campaigns/view/5

to be able to use the application.

That would not be a real issue but it becomes one when I get to the landing page functionality. When I create a landing page and insert it into an email, the generated link looks like

http://.../mautic/landing-page-part?ct=...tracking...code...

This URL generates a 404, because the application expects the …/index.php/… part which is there when I work with the frontend but is missing in the generated landing page URL.

My very limited technical skills tell me that something is wrong with the URL rewrite - maybe it is not. :slight_smile:

Any ideas?

Peter

Hey guys,

I created a hosted Mautic account and there is indeed a difference between this application and the one I installed on my server. The Mautic hosted application dashboard URL is

https://....mautic.com/s/dashboard

where mine is

http://.../mautic/index.php/s/dashboard

I am pretty sure now that something goes wrong with the URL rewrite, the /index.php should not be there. And I guess when it is not in the URL, both landing page and and tracking will work fine.

Any idea what is configured wrong in my web server?

Peter

Hi Peter

This is definitely related to a configuration mod_rewrite issue. Couple questions:

  • Can you confirm your web engine? Is it apache?
  • Confirm if mod_rewrite is enabled?
  • Confirm the .htaccess file sent with mautic is on the server?

Its possible Apache may need to be configured to allow overrides in your web root:
http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride

Hi Chad, please find my answers inline:

I am running Apache version 2.4.7 on a Linux server.

In the Loaded Modules section of phpinfo(), mod_rewrite is listed.

Yes, the .htaccess file is on the server.

[quote]Its possible Apache may need to be configured to allow overrides in your web root:
http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride[/quote]
I inserted the following into apache2.conf and restarted the Apache service:

<Directory /var/www/http/mautic> Options Indexes FollowSymLinks AllowOverride All Require all granted </Directory>

Unfortunately after inserting and restarting, the Mautic application (via http://…/mautic) produces a redirection to http://…/mautic/s/dashboard and results in a 404 (“The requested URL /mautic/s/dashboard was not found on this server.”).

This is the point where it gets intransparent for me. Is the apache2.conf the correct place to put the code or does it have to be the .htaccess file for the /mautic directory?

Peter

I just found the solution - and it is rather strange/stupid. I checked the (delivered) .htaccess file and the first line was

e the front controller as index file. It serves as a fallback solution when

although it should have been

#Use the front controller as index file. It serves as a fallback solution when

Somehow the first three characters went missing. Strange thing, however: solved.