Mautic Community Forums

Landing pages throwing 500 error after upgrade to 3.0.2 from 2.16

My Mautic version is: 3.0.2
My PHP version is: 7.2.30

After upgrading to Mautic 3.0.2, my landing pages are now throwing a 500 error. I can edit them fine, just can’t view or preview them.

These errors are showing in the log:
[2020-07-28 09:38:23] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalThrowableError: “Call to a member function getIntegrationSettings() on boolean” at D:\home\site\wwwroot\mailer\app\bundles\NotificationBundle\EventListener\PageSubscriber.php line 51 {“exception”:"[object] (Symfony\Component\Debug\Exception\FatalThrowableError(code: 0): Call to a member function getIntegrationSettings() on boolean at D:\home\site\wwwroot\mailer\app\bundles\NotificationBundle\EventListener\PageSubscriber.php:51)"}

I have not attempted any steps to fix the problem as I’m not sure where to start.

Thanks for any assistance you can provide!

2 Likes

Same issue occurs upgrading from 2.16.3 to 3.0.1.

Getting same 500 error from landing pages.

I have also tried a fresh install. Same error there.

Still seeing the same 500 error with Mautic 3.1 :frowning:

Also got the same 500 error on landing pages (upgraded from Mautic 2.16 or newly created in Mautic 3) after upgrading to Mautic 3.0. Editing worked but view/ preview generated errors just like you report. Have rolled back update to v2.16.

Yep. Keep rolling back to 2.16.3 also.

Still get the same error when upgrading to Mautic 3.1.1. Am running on Windows IIS with Mariadb 10.4. As a test tried to create fresh Mautic 3.1.1 instance with a fresh database. Got the same error on landing pages. Repeated fresh Mautic 3.1.1 install with MySQL 8.0.21 and got the same error on landing pages.

Opened PageSubscriber.php and saw that on line 50-51 it says:

$integrationObject = $this->integrationHelper->getIntegrationObject(‘OneSignal’);
$settings = $integrationObject->getIntegrationSettings();

A check on Settings> Plugins shows that the OneSignal plugin along with several others is not loaded. Opening the database and checking the table (prefix)plugin-Integration_settings shows that entries for OneSignal & Twilio are missing.

Tried the local.cfg modifications suggested in this similar problem report from Bitnami but it did not fix the issue.

Just noticed that there was fix in the works( #9274). I edited IntegrationHelper.php as suggested in the fix. It works! Now the missing plugins are visible and the landing pages work in the upgraded 3.1.1 Mautic installation.

Any idea when the patch/ update for this will be available?