Mautic Community Forums

Leads saved as Bulgaria Montana

Hello, I am making great progress with Mautic but just stumbled upon an issue I am unable to resolve.



Leads from the state of Montana in the United States are being saved as Bulgaria Montana.



You can edit the leads, and change the state to United States Montana and then save the lead and it will correctly stay saved as United States Montana… However, the next time you edit the lead it reverts back to Bulgaria Montana again.



Does anyone else have this issue?

Hello, I am making great progress with Mautic but just stumbled upon an issue I am unable to resolve.

Leads from the state of Montana in the United States are being saved as Bulgaria Montana.

You can edit the leads, and change the state to United States Montana and then save the lead and it will correctly stay saved as United States Montana… However, the next time you edit the lead it reverts back to Bulgaria Montana again.

Does anyone else have this issue?

Try a different IP lookup service. You can find it in Mautic’s configuration in the “Miscellaneous Settings” at the bottom of the page.

thanks for the reply, but that isn’t the problem.

Here are the steps to reproduce the issue:

  1. Manually add a lead and for the state enter United States Montana.
  2. Save it.
  3. Re-edit the lead.

Expected Result: the state is still set to United States Montana.

Actual Result: the state gets automatically set to Bulgaria Montana.

Yes, that’s a bug. I can replicate it. Would you be so kind and report it to https://github.com/mautic/mautic/issues ? That way developers won’t overlook it here. I could do it myself, but then you wouldn’t get notifications about the progress. If you create a GH issue, please, add a link to it here so others know where it is.