"List-Unsubscribe" in the header of emails is missing

I’m having problems with “List-Unsubscribe” header in emails that are sent with Mautic. I have enabled in Settings/Configuration/Email Settings (as you see in the picture) and also in each email advanced settings. I tried each setting alone and together, and still, emails end up in spam without “List-Unsubscribe”. I’m using Sendgrid API and when I enable Tracking settings in Sendgrid, they insert the sentence “If you’d like to unsubscribe and stop receiving these emails <% click here %>” at the bottom of the email which I don’t want. Anyone had similar problems and possibly solution to this?