Mautic Community Forums

Mautic 1.3.0 Allowed memory size

Hello today I entered my nautic to check my leads, and I find this error message memory, I have the version 1.3.0, I increased the memory from 164M to 256M but equally the message appears.

Quote:
Fatal error: Allowed memory size of 192937984 bytes exhausted (tried to allocate 87 bytes) in /home/hugodel/public_html/odverorodriguez/mautic/app/bundles/LeadBundle/Entity/LeadRepository.php on line 542

Hello today I entered my nautic to check my leads, and I find this error message memory, I have the version 1.3.0, I increased the memory from 164M to 256M but equally the message appears.

[quote]
Fatal error: Allowed memory size of 192937984 bytes exhausted (tried to allocate 87 bytes) in /home/hugodel/public_html/odverorodriguez/mautic/app/bundles/LeadBundle/Entity/LeadRepository.php on line 542[/quote]

I received a similar error during the initial launch of Mautic.

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 64 bytes) in /home/valmathews/public_html/mautic/app/bootstrap.php.cache on line 2704

I was able to fix this fatal error. I talked to my hosting company and they walked me through tweaking things. Problem fixed.

BEFORE you install Mautic, do these tweaks so you don’t get a fatal error message at the end of the launch and Mautic will not install. (The following instructions are for GoDaddy’s cPanel. They may be slightly different depending on your cPanel configuration):

Go to cPanel
Scroll down to Software section
Click on “Select PHP Version”
Change PHP version to the highest listed (see http://php.net/supported-versions.php for what versions of php)
Put a checkmark next to “intl” and “memcached” (NOT memchache BUT memchached with a d).
SAVE
Click blue button in the upper right that says “Switch to PHP Extensions”
Change memory limit to 256 (need at least 128)
SAVE
Go back to cPanel
Scroll down to software section
Click “Optimize Website”
Check “Compress all content”
Click “Update Settings”
Go back to cPanel
Scroll down to software section
Click “PHP Processes”
Click “Kill Processes”
Check websites to make sure everything still looks right