Mautic Community Forums

memory size of 536870912 bytes exhausted

Anybody seen this error before? Cleared cache, rebooted, same message thrown into log.





ERROR: Fatal: Allowed memory size of 536870912 bytes exhausted (tried to allocate 81 bytes) - in file //vendor/doctrine/orm/lib/Doctrine/ORM/Internal/Hydration/ObjectHydrator.php - at line 588 [] []

Anybody seen this error before? Cleared cache, rebooted, same message thrown into log.

ERROR: Fatal: Allowed memory size of 536870912 bytes exhausted (tried to allocate 81 bytes) - in file //vendor/doctrine/orm/lib/Doctrine/ORM/Internal/Hydration/ObjectHydrator.php - at line 588 [] []

Try to increase your memory_limit in the php config file.

I had this fatal error, too, when I tried to launch the install. (Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 72 bytes) in /home/valmathews/public_html/mautic/app/bootstrap.php.cache on line 2704.) I talked to my hosting company and they walked me through tweaking things. Problem fixed.

BEFORE you install Mautic, do these tweaks so you don’t get a fatal error message at the end of the launch and Mautic will not install. (These instructions are for GoDaddy’s cPanel. They may be slightly different depending on your cPanel configuration):

Go to cPanel
Scroll down to Software section
Click on “Select PHP Version”
Change PHP version to the highest listed (see http://php.net/supported-versions.php for what versions of php)
Put a checkmark next to “intl” and “memcached” (NOT memchache BUT memchached with a d).
SAVE
Click blue button in the upper right that says “Switch to PHP Extensions”
Change memory limit to 256 (need at least 128)
SAVE
Go back to cPanel
Scroll down to software section
Click “Optimize Website”
Check “Compress all content”
Click “Update Settings”
Go back to cPanel
Scroll down to software section
Click “PHP Processes”
Click “Kill Processes”
Check websites to make sure everything still looks right