Mautic Community Forums

Fatal error before installing.

I have been struggling with Installation lately, tried the gihub repository, tried previous versions, I always get the same error;

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 32 bytes) in /home/public_html/mautic/app/bootstrap.php.cache on line 2704



Tried to allocate more memory trough htaccess file, it only produced a 500 internal server error at every try.



I’ve tried to locate my php.ini to allocate more memory, but couldn’t find it in my hosting, so I tried contacting my hosting provider, I confirmed I got 2048MB and there’s no limitations on memory usage for PHP.



Today out of the blue it worked, I got to the installation page, but after finalizing page 3, I’m back at square one, with the exact same problem. I scoured the web but couldn’t find an answer that would work with my instance.



I’ve already installed and run Vtiger, sugarCRM, SuiteCRM, opencart, among others. I configured my joomla, wordpress and phpbb with minor problems.



It’s probably a minor setback, maybe in the future I’ll remember it and laugh. But as for now, I can’t figure it out.



Anyone had a problem like this? Any ideas?



Thanks!



Hermes Sandoval

Hi Hermes,

Did you end up resolving this issue?

Thanks,

Ray

I have been struggling with Installation lately, tried the gihub repository, tried previous versions, I always get the same error;
Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 32 bytes) in /home/public_html/mautic/app/bootstrap.php.cache on line 2704

Tried to allocate more memory trough htaccess file, it only produced a 500 internal server error at every try.

I’ve tried to locate my php.ini to allocate more memory, but couldn’t find it in my hosting, so I tried contacting my hosting provider, I confirmed I got 2048MB and there’s no limitations on memory usage for PHP.

Today out of the blue it worked, I got to the installation page, but after finalizing page 3, I’m back at square one, with the exact same problem. I scoured the web but couldn’t find an answer that would work with my instance.

I’ve already installed and run Vtiger, sugarCRM, SuiteCRM, opencart, among others. I configured my joomla, wordpress and phpbb with minor problems.

It’s probably a minor setback, maybe in the future I’ll remember it and laugh. But as for now, I can’t figure it out.

Anyone had a problem like this? Any ideas?

Thanks!

Hermes Sandoval