Mautic 4.0 support for PHP 8.0

Your software
My version PHP 8.0
Raspberry pi running Raspberry OS Lite.

Hello, I am looking to install Mautic 4.0 on my Raspberry pi as a side project.
Realized that PHP 8.0 support for Mautic is in progress. - Requirements

Looking to see if there is any information about when PHP 8.0 support will be available.

I could roll back to the previous version but wanted to check first if there is any information.
Thank you!!

What is the current status of PHP 8 support? Is that still part of Mautic 5?

I tried. Mautic loads with the menu on the left side, but 500 server errors on all pages - Dashboard, Calendar, Contacts, etc.:

Oops! An Error Occurred
The server returned a “500 Internal Server Error”.

Not a huge problem. I’ll just stay on PHP 7.4 for now. My websites were a mess as well. I have a lot of clean-up to do before I can upgrade I guess.

Edit: I see there was another thread about this here, with promise of PHP 8 support in Mautic 5.

And I see others have had no problems with PHP 8.0. This is the error in my logs:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 32768 bytes) in /home/username/public_html/mautic/app/bundles/LeadBundle/Tracker/ContactTracker.php on line 358

I know how to “fix” that, but just FYI for @rcheesley and team etc. I guess installing another PHP version resets the configuration to pathetic defaults?

8.0 support is already shipped. 8.1 had dependencies on Symfony 5 so it’s not yet released, it will require breaking changes.

1 Like

Yeah I am running Mautic 4.4.5 on php 8.0 without issue.


Switched to PHP8, but still get the same 500 Internal Server Errors on all pages - Dashboard, Calendar, Contacts, etc., left-side menu loads fine. Logs has this possible cause:

Allowed memory size of 33554432 bytes exhausted (tried to allocate 65536 bytes) 

But even turning off memory_limit doesn’t fix it, even after restarting apache and apache_php_fpm.

Or should I look for other error logs for ‘server returned a “500 Internal Server Error”’?

I tried clearing the cache via SSH, to see if that would make a difference, but got this error:

In CacheClearSubscriber.php line 46:

Failed to clear FilesystemTagAwareAdapter

cache:clear [--no-warmup] [--no-optional-warmers] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-e|--env ENV] [--no-debug] [--] <command>

Never seen that error before, so have to assume it has something to do with the switch to PHP8.

What else could I try?

Upgrading to PHP8 changed my Apache user to ‘nobody’. It turned out I had to enable the Apache Module mod_suexec in EasyApache4 to set the user back to ‘myusername’, which cleared up the 500 Internal Server Errors. Everything seems OK now. :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.