Mautic Community Forums

Mautic adds HTML style code in emails

I have a problem with emails Mautic 2.1.0. and also 2.1.1. I am using a custom email template. When I copy the HTML code to Mautic email editor, it adds:

style=“border: 1px solid rgb(221, 221, 221);” to every

tag

and style="-webkit-user-select: none;" to every tag.



I need to disable it somehow because it really messes the email style.

I have a problem with emails Mautic 2.1.0. and also 2.1.1. I am using a custom email template. When I copy the HTML code to Mautic email editor, it adds:
style=“border: 1px solid rgb(221, 221, 221);” to every

tag
and style="-webkit-user-select: none;" to every tag.

I need to disable it somehow because it really messes the email style.

the same problem

Mastic’s content editor is changing custom html code on save. I can only speculate on why, but there doesn’t seem to be a fix coming anytime soon. One workaround is to paste your custom code directly into the sql table. It’s clunky and takes some figuring out of exactly where to find the right field if you’re not an sql jockey, but it does work.

Did someone find a better solution?

I find it very uncomfortable to have to modify every email in sql