Mautic Community Forums

Mautic API with Thrive

Hi everyone,



First of all, I’m french, so sorry if I make some mistakes.



I bought Thrive Leads today and I tried to make the connection between Mautic and the plugin Thrive but it doesn’t work.



I create an API Oath1 in Mautic, that’s ok. I made a connection in Thrive (Oath 1 too) and when I tried to validate, I have a message “The connection didn’t work.” The Error message is empty.



Do you have some idea to help me ?

Hi everyone,

First of all, I’m french, so sorry if I make some mistakes.

I bought Thrive Leads today and I tried to make the connection between Mautic and the plugin Thrive but it doesn’t work.

I create an API Oath1 in Mautic, that’s ok. I made a connection in Thrive (Oath 1 too) and when I tried to validate, I have a message “The connection didn’t work.” The Error message is empty.

Do you have some idea to help me ?

Here is how I did it, and it worked flawless. If that does not work for you perhaps you should detail your environment because that is most likely where the problem is.

https://www.youtube.com/watch?v=Ir4CkL9n6_o

I did exactly as you do in the video. In fact, I used the video to help me.

I’m on Wordpress. Mautic & Wordpress are on the same 1&1’s hosting.

I don’t know what you need, so I paste here part of my System Info :

PHP Version 5.6.24
System Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux
Build Date Jul 25 2016 07:13:53
Configure Command ‘./configure’ ‘–build=x86_64-linux-gnu’ ‘–prefix=/usr’ ‘–includedir=${prefix}/include’ ‘–mandir=${prefix}/share/man’ ‘–infodir=${prefix}/share/info’ ‘–sysconfdir=/etc’ ‘–localstatedir=/var’ ‘–disable-silent-rules’ ‘–libdir=${prefix}/lib/x86_64-linux-gnu’ ‘–libexecdir=${prefix}/lib/x86_64-linux-gnu’ ‘–disable-maintainer-mode’ ‘–disable-dependency-tracking’ ‘–program-suffix=5.6’ ‘–libdir=/usr/lib/php5.6’ ‘–with-config-file-path=/usr/lib/php5.6’ ‘–with-pear=/usr/lib/php5.6’ ‘–bindir=/usr/bin’ ‘–includedir=/usr/include’ ‘–with-zlib’ ‘–enable-debug=no’ ‘–enable-safe-mode=no’ ‘–enable-discard-path=no’ ‘–with-gd’ ‘–with-png-dir’ ‘–enable-track-vars’ ‘–with-db’ ‘–with-gdbm’ ‘–enable-force-cgi-redirect’ ‘–with-ttf’ ‘–enable-ftp’ ‘–with-mcrypt’ ‘–enable-memory-limit’ ‘–enable-calendar’ ‘–enable-wddx’ ‘–enable-bcmath’ ‘–enable-gd-imgstrttf’ ‘–enable-shmop’ ‘–with-openssl’ ‘–with-dom’ ‘–with-dom-xslt’ ‘–with-dom-exslt’ ‘–with-imap’ ‘–with-curl’ ‘–with-iconv’ ‘–with-freetype-dir’ ‘–with-bz2’ ‘–with-gettext’ ‘–enable-exif’ ‘–enable-mbstring=all’ ‘–with-kerberos’ ‘–with-sqlite’ ‘–with-imap-ssl’ ‘–with-libxml-dir’ ‘–with-xsl’ ‘–with-xslt-sablot’ ‘–with-jpeg-dir’ ‘–with-tidy’ ‘–enable-soap’ ‘–enable-xslt’ ‘–enable-sqlite-utf8’ ‘–enable-zip’ ‘–enable-intl’ ‘–with-mysqli=mysqlnd’ ‘–with-pdo-mysql=mysqlnd’ ‘–with-mysql=mysqlnd’ ‘–enable-opcache’ ‘build_alias=x86_64-linux-gnu’ ‘CFLAGS=-g ‘-O2’ ‘-fPIE’ ‘-fstack-protector-strong’ ‘-Wformat’ ‘-Werror=format-security’’ ‘LDFLAGS=-fPIE ‘-pie’ ‘-Wl,-z, relro’ ‘-Wl,-z, now’’ ‘CPPFLAGS=-D_FORTIFY_SOURCE=2’ ‘CXXFLAGS=-g ‘-O2’ ‘-fPIE’ ‘-fstack-protector-strong’ ‘-Wformat’ ‘-Werror=format-security’’
Server API CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /usr/lib/php5.6
Loaded Configuration File …/mautic/php.ini
Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20131106
PHP Extension 20131226
Zend Extension 220131226
Zend Extension Build API220131226, NTS
PHP Extension Build API20131226, NTS
Debug Build no
Thread Safety disabled
Zend Signal Handling disabled
Zend Memory Manager enabled
Zend Multibyte Support provided by mbstring
IPv6 Support enabled
DTrace Support disabled
Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, tls, tlsv1.0, tlsv1.1, tlsv1.2
Registered Stream Filters zlib., bzip2., convert.iconv., mcrypt., mdecrypt., string.rot13, string.toupper, string.tolower, string.strip_tags, convert., consumed, dechunk

Also, if you include a slash ("/") at the end of your Mautic URL that you paste into Thrive during setup, that will fail as well.
So, make sure there’s NO slash at the end of the URL (to your Mautic installation) that you paste into Thrive.

Ok, just to let you know, I find this morning there was a problem with the plugin Evergreen. After disabling it, it works perfectly well. Thank you all for your help.

Have a nice day !

The following happened:
With help of my website hosting provider we added the following code to .htaccess

php_flag display_errors on

This provided the 500-error code which I then gave back to them.
In my case it gave a Fatal error with “‘cURL error 35: SSL connect error’ in ”

My hosting provider could tell there was a conflict in curl-versions between both servers. They updated their curl versions.

This has helped! because I now have a working OATH1 api connection in ThriveLeads with Mautic.