Mautic Community Forums

Mautic behind firewall - NAT IP issue

Evaluating Mautic. Seems great so far but running into config issue.

I have a bitnami VM running on ESXI.

Mautic v2.0 with latest updates.

Everything is behind a firewall.

I have public IP’s mapping to internal machines.

Internal machines have internal IP addresses.

Mautic has static Internal IP

Firewall have public IP mapped to mautic’s internal IP

I can access mautic with external IP, outbound mail test working.

Made public DNS entries to external IP address for mautic.

Can access Mautic using external IP address and the DNS entry.

In configuration settings/general settings, the site url displays the internal IP address/mautic (eg. http://10.200.200.200:80/mautic)

If I change it to our dns entry http://mautic.domain.com:80/mautic … and then save.

If I go through the GUI and back to that setting, it is still set.

If I reboot the server and go back to that setting, it is back to using the internal IP address.

I obviously want it to use our public DNS entry and/or at least the external IP address. Basically the setting is not sticking after reboot.



I have raised this issue on Bitnami’s forum but I have not had a useful response.

Evaluating Mautic. Seems great so far but running into config issue.
I have a bitnami VM running on ESXI.
Mautic v2.0 with latest updates.
Everything is behind a firewall.
I have public IP’s mapping to internal machines.
Internal machines have internal IP addresses.
Mautic has static Internal IP
Firewall have public IP mapped to mautic’s internal IP
I can access mautic with external IP, outbound mail test working.
Made public DNS entries to external IP address for mautic.
Can access Mautic using external IP address and the DNS entry.
In configuration settings/general settings, the site url displays the internal IP address/mautic (eg. http://10.200.200.200:80/mautic)
If I change it to our dns entry http://mautic.domain.com:80/mautic … and then save.
If I go through the GUI and back to that setting, it is still set.
If I reboot the server and go back to that setting, it is back to using the internal IP address.
I obviously want it to use our public DNS entry and/or at least the external IP address. Basically the setting is not sticking after reboot.

I have raised this issue on Bitnami’s forum but I have not had a useful response.