Mautic Community Forums

Mautic Tracking Script and Nginx

Hello,



I’m completely new to Mautic (private server), and I’m trying to figure a couple of things out. I seem to have figured out the tracking pixel (mtracking.gif) and I am able to see/track anonymous users using it on one of my sites. However, I seem to be having issues working with the tracking script (mtc.js). I have it installed as a copy and paste (copy from mautic config page and paste into the body section) in one of my sites (non-joomla site), and I have installed it via the Joomla plugin on one of my other sites.



I have then logged out of Mautic and opened a private window in a different browser to see if I can test the tracking script. According to the web console on the private browser, mtc.js gets a 200 response on both sites. However, I cannot seem to find my activity in Mautic either as a visitor, or a known contact.



I checked my Nginx access log and I saw an entry that looked like I was spotted, but I’m not seeing anything in Contacts in Mautic. What am I missing???



I’m running Mautic 2.1.1

PHP 7.0.8

Nginx 1.10

Hello,

I’m completely new to Mautic (private server), and I’m trying to figure a couple of things out. I seem to have figured out the tracking pixel (mtracking.gif) and I am able to see/track anonymous users using it on one of my sites. However, I seem to be having issues working with the tracking script (mtc.js). I have it installed as a copy and paste (copy from mautic config page and paste into the body section) in one of my sites (non-joomla site), and I have installed it via the Joomla plugin on one of my other sites.

I have then logged out of Mautic and opened a private window in a different browser to see if I can test the tracking script. According to the web console on the private browser, mtc.js gets a 200 response on both sites. However, I cannot seem to find my activity in Mautic either as a visitor, or a known contact.

I checked my Nginx access log and I saw an entry that looked like I was spotted, but I’m not seeing anything in Contacts in Mautic. What am I missing???

I’m running Mautic 2.1.1
PHP 7.0.8
Nginx 1.10