Mautic Update Composer 5.0.2. to 5.0.3. | Not Updating mautic/core-lib

Your software
My Mautic version is: 5.0.2
My PHP version is: 8.2.
My Database type and version is: SQL

Your problem
My problem is: Hey I am currently running a test machine with Mautic 5.0.2
Now I want to update to Mautic 5.0.3 and the Composer is simply not updating the Mautic core-lib. Everythin else is updated but not the core itself.
I found a similar issue but not for Mautic 5

Steps I have tried to fix the problem:
I tried alreay the method presented in the post, but without success. Is anyone else having issues with updating with Composer to 5.0.3?
So I tried to manually change the composer.json and clearing the cache. I checked this instruction again but I stuck on 5.0.2

I like to have the update because the API issue is fixed in 5.0.3 :slight_smile:

Thank you in advance for ideas and comments

I’m running into the same issue, after updating with:

  • composer update mautic/core-lib --with-dependencies
  • clearing the cache and making sure all perms are correct.

Still seeing 5.02 in the footer.

If I execute the composer update command. I get the following output

Loading composer repositories with package information                              Updating dependencies
Nothing to modify in lock file
Installing dependencies from lock file (including require-dev)
Nothing to install, update or remove
Package sensio/framework-extra-bundle is abandoned, you should avoid using it. Use Symfony instead.
Generating autoload files
120 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
Deprecation Notice: Return type of Mautic\Composer\Plugin\Scaffold\Operations\ScaffoldFileCollection::getIterator() should either be compatible with IteratorAggregate::getIterator(): Traversable, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /var/www/mautic/vendor/mautic/core-composer-scaffold/Operations/ScaffoldFileCollection.php:118
Scaffolding files for mautic/core-lib:
  - Copy [project-root]/package-lock.json from assets/scaffold/files/package-lock.json
> npm ci --prefer-offline --no-audit
npm WARN deprecated stable@0.1.8: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN:
npm WARN deprecated @npmcli/move-file@1.1.2: This functionality has been moved to @npmcli/fs

> mautic@0.0.0 postinstall
> node_modules/modernizr/bin/modernizr -c modernizr-config.json -d node_modules/modernizr/modernizr-mautic-dist.js & npm run build

Modernizr build saved to node_modules/modernizr/modernizr-mautic-dist.js

> mautic@0.0.0 build
> webpack --mode production  --config webpack.config.js

Browserslist: caniuse-lite is outdated. Please run:
  npx update-browserslist-db@latest
  Why you should do it regularly:```

I tried the npx update without succes. Anyone ideas what I can try?
Is there anything about the npm WARNings?
Thank you :)