Mautic v3.3.3 + Whitelabeller Latest - No Dashboard/Links/etc

Your software
My Mautic version is: 3.3.3
My PHP version is: 7.4
My Database type and version is:

Your problem
My problem is:
After installing a clean install of v3.3.3 and the latest version of whitelabeller, all links break and the dashboard just shows loading icons ?

These errors are showing in the log:
There are no errors in the mautic.error log - where else can I be looking

Steps I have tried to fix the problem:
chown the directory

Weird. Works for me.
Https ok?
J

Nope. I am setting it up on a server inside a VPN that does not have access outside.

Does https make a difference here ?

what is most frustrating is nothing in any logs files to show what is going on
. I am running on a LEMP stack

just went and fired up a new server and added https to it. https is all good.

This is the only thing I am seeing in the console:
image

This is driving me a bit mad. I have tried the following:

  1. Watching the mautic.error log
  2. Watching nginx error.log
  3. Watching mysql logs
  4. Removed cache with rm -rf on /var/cache
  5. Ran update data schema

I am able to hit internal pages if I add in the url manually like /s/contacts or /s/email but links inside do not work, for example you cannot click on settings.

Well,

Mautic is a very simple tool if after fresh installation it’s not working.

I suggest check required PHP modules, file permission, etc

Something is missing that’s why its not working and HTTPS is not an issue

because on my application its working fine in both ways.

Thanks for the reply.

Have done all those things. @joeyk was kind enough to even jump on a quick google meet to see the problem - it is still a bit mystery to everyone.

What is interesting is if anyone else can reproduce this.

The steps I have taken to result in this was to fire up a new server (did this on digital ocean and AWS)

Installed both LEMP and LAMP stack on two different servers. Following directions the aforementioned links.

Installed Mautic from zip on GitHub, following directions here: Install Mautic Self-Hosted Email Marketing on Ubuntu 20.04

Got Mautic up and running and everything is working great.

Next is I go and download whitelabeller: GitHub - nickian/mautic-whitelabeler: Easily change the logos, colors and company name in the Mautic user interface.

Whitelabel something and then the behaviour starts happening

Are you installing from the Features branch?

If so that will be Mautic 4 Beta. Just wanted to check as the plugin may not have been updated for that yet.

Nope. I am installing version 3.3.3. I have also tried with version 3.3.2 and 3.3.1.
No idea what it can be. Maybe something with the whitelabeller (however I have tried previous versions of this.) I am at a loss.

Yeah - here’s hoping that the maintainer is able to help troubleshoot!

Hi All,

I have done some extensive testing here and am actually wondering if this has something to do with v3.3.3 (although not sure)

What I did was install a vanilla version of 3.2.0, used an old version of whitelabeller and everything worked well.

Updated Mautic to 3.3.3, and hacked WL by changing the compare.php file and copying the template/3.2.0 to 3.3.3.

Ran white labeler and it seemed to work… mostly. Dashboard is showing, however certain menu items are not working now.

Seeing stuff like this in the console

image

Notified the maintainer over github Mousetrap is not defined · Issue #108 · nickian/mautic-whitelabeler · GitHub

Thanks, I also put a note to him and also wrote on your thread.

After much work today I am not sure it is the plugin error, I think it could have something to do with missing php7.4 dependancies… Check out the thread you opened on GitHub for more details.

This issue has been resolved. It seems that I was installing Mautic 3.3.3-update.zip which was the problem.

The developer Nick was super helpful and I can say that from all the community we are grateful for the plugin he has provided.

For those that are interested you can check out the full thread in the Issues page on GitHub, I have also posted a small code implementation if someone is having this error on 3.3.3-update.

3 Likes

I Think I’m missing something. I have the same issue but on v4 I upgraded within mautic from 3.0 to 3.3 to 4.0.0 in mautic when running the whitelabeller i get this msg:

“The version of Mautic you are using (4.0.0) is not currently supported.”

so is that where things stand at the moment?

Hey,
The whitelabeler is always couple weeks behind.
You need to wait for the 4.0.0. whitelabeler template to be ready or create one yourself.
Joey

a little hack here is to edit the compare.php file and add in the following:
$v3_path = '…/4.0.0;

$compare = $whitelabeler->compareMauticVersions($v1_path, $v2_path, $v3_path);

save that.
Then go into the templates directory and copy the latest template for example
cp -R 3.3.3 4.0.0
chown -R www-data:www-data 4.0.0

And you should be good to go