Mautic whitelabler not working on bitnami image from aws

Hey guys, I’m pretty new to the mautic world. I’ve installed mautic on a EC2 instance on AWS from the bitnami image from the marketplace. I’m running version 4.4.6 and tried to whitelable my instance with the whitelabler from nickian with version 2.3.2.

I’ve tried to access the whitelabler through the frontend but can’t manage to open it - I think bitnami changed the file structure and blocked any outside access to files. Despite of whitelist it in the htaccess I can’t access it. So then I tried the cli variant but get there an error when I try to make a backup. I haven’t dared to start the whitelable process yet.

php error at backup process
PHP Fatal error:  Uncaught UnexpectedValueException: DirectoryIterator::__construct(templates): Failed to open directory: No such file or directory in /opt/bitnami/mautic/mautic-whitelabeler/whitelabeler.php:693
Stack trace:
#0 /opt/bitnami/mautic/mautic-whitelabeler/whitelabeler.php(693): DirectoryIterator->__construct()
#1 /opt/bitnami/mautic/mautic-whitelabeler/whitelabeler.php(166): Whitelabeler->templateVersions()
#2 /opt/bitnami/mautic/mautic-whitelabeler/cli.php(149): Whitelabeler->mauticVersion()
#3 {main}
  thrown in /opt/bitnami/mautic/mautic-whitelabeler/whitelabeler.php on line 693

Had somebody the same issues and can help out?

I just updated to the last Mautic Version and tried with the corresponding whitelabler Version but have the same behaviour…

Am I the only one with this misfunction?


Just that I undrestand correctly:

Are you trying to use the Mautic Whitelabeler 2023 september version on Mautic 5?


Hey joeyk,

nope. I’m on Mautic Version 4.4.11 after the update.

Well, then your assumption might be right:

I think bitnami changed the file structure and blocked any outside access to files.

It’s really hard (and counterproductive) to support bitnami and softaculus installs.
It is always better to ask them what they did and why.

As I’m still not in production and have used the bitnami service to make things easier to handle but it now turn out that it makes overcomplicated several things…
What would you suggest is the best way to install and run mautic nowadays?
I would prefer to stay on the AWS stack but am open for other suggestions.
Appreciate your help!

It seems the repo was updated in the last 24 hours, you may want to try again.

I’ve seen it, thank you. But unfortunately it does not solve the problem as it seems it is not from the whitelabler but from the bitnami configuration :confused:

1 Like