Mysterious broken image links after upgrade to 4.4.6

Your software
My PHP version is : 7.4.33
My MySQL/MariaDB version is (delete as applicable): MySQL/MariaDB version

Updating/Installing Errors
I am (delete as applicable): Updating
Upgrading/installing via (delete as applicable) : Command Line

Your problem
My problem is :
After upgrading to 4.4.6 last week, everything seemed normal but this week we noticed that some of the image links are broken and not displaying in email clients. After inspecting further, it appears that some images do not have https prefixes and are being blocked.

We have always had SSL so I assume the images used to have https prefixes since they used to display normally. I could be wrong about that, not sure how to verify after the fact.

Is there some reason that the upgrade would rewrite the image URLs? Or maybe Mautic has changed its behavior in some way for presenting the images after this upgrade?

Any thoughts on what might have happened and how to troubleshoot would be very welcome!

1 Like

Bumping this to see if anyone has any ideas?

To be more clear, after the upgrade we started seeing that our images weren’t showing in emails.

When investigating, I discovered that some of our image links in the emails had “http” prefixes. However, when we went into the builder to edit the emails and relink images to the emails, suddenly the emails had https prefixes in the URLs and started working normally.

It looks like the reason the images weren’t showing is because they had http links.

I’m trying to understand a couple things. What happened during the upgrade that would have changed the way Mautic assigns the image address when relinking?

Also, could something have changed in Mautic that impacted the way the email clients handle our email images? If they were previously served without SSL, what changed to make the email clients suddenly care? Did something in Mautic core recently change that would have impacted this?

Something especially strange is that the http image links will display in email previewer, both inside Mautic and in external previewers, but the image will not display in a regular browser tab. When I open the direct link to the image it shows the error " Not Found The requested URL was not found on this server." Maybe a clue to the way the image is being handled/served?

Any ideas or hints would be helpful!

1 Like

Is it possible the issue is with the email client and not Mautic? If your website has always had SSL, the images may have been served initially over https, but the URLs did not include the prefix. In this case, the photos would have still been displayed in email clients, but recent changes to email security protocols may now be blocking them.

1 Like

I thought that might be the case but didn’t see anything on Google about recent security updates to gmail.

But since this post I did solve part of the puzle – I saw that clearing cache would solve this error in different cases so cleared cache and the http images are showing again. Not clear why the original cache clearing after the upgrade wouldn’t have solved this but it nonetheless worked this time.

But that doesn’t explain why Mautic is now attaching the images using https URLs when before it was using http? Did something recently change in the Mautic core that forces https for images on instances using SSL?

1 Like

I believe Mautic generates a unique URL for images, and if you have SSL it will generate an https link. There used to be a section on mautic documentation about this, but I haven’t been able to find it since they reorganized it.

1 Like

Thank you for the replies and feedback! I will keep my eyes open.

1 Like