Mystery Tracking Issue


We have the weirdest issue at the moment. We have gone ahead and created a number of forms for a client. Initially this was done on their domain.
The flow of information was to fill out one form with basic information, then on completion of the form to be taken to a second form and to fill that out as a questionnaire. All fields were then stored in the new Contact Card created. At this point everything worked perfectly.

We then went and moved the Wordpress site to a new domain and now the results from Form2 are not being stored in the new user card.

I do not even know where to start looking.

I have tried to make new forms to test, still on new site it is not working. I have made sure WPMautic is installed correctly and tracking script is there.

Any ideas ?

Does it happen with all browsers?
Wordpress “security” and “firewall” plugins deactivated to troubleshoot?
Modsecurity active on server?

Hey @EJL

Thanks for the prompt reply.

  1. Actually not on all browsers. Chrome and Safari are not playing well with it. However Firefox seems to eb tracking all the way through.

  2. It is the most basic installation on Wordpress. I do not even see security or firewall in any tools/settings (I am far from a Wordpress expert so maybe I am missing something).

  3. I have checked mods-enabled on the server and do not see modsecurity.

are there any logs I can be checking or any other way I can go about debugging it

I have spent the whole day playing with different variations, different installations on mautic and Wordpress and just cannot figure this out.

I did manage to get the exact same scenario working in a different installation of Wordpress and mautic, however on the instances I need it is just not catching.

So @EJL or anyone out there that can think of a way to debug this I would be very appreciative.



Chrome-Right click - Inspect page. Leave those open while you test. Look for errors like this. (Tracking was blocked by my browser or one of my extensions.

Hey @EJL

I got really excited when I used the console as I saw a stupid error (while checking was calling a different mautic) but I fixed that error and see things are not working as was before.

I am not getting any errors in the console, it is fully clean. No http or https errors or warnings or even info.

But still from one form to the next it is generating a new contact for each form.

After spending multiple hours tracking this, and looking for cookies being dropped etc… and spending time with a developer I think I should mentioned is that mautic is sitting on domain x and new website is sitting on domain y.

Could this be an issue ?

In the original example mautic was on and website was on
In new setup mautic is on and new website is on

Check in the tracking config to see what url is present in the box. If this was a cloned install this URL may be incorrect

Thanks @EJL - the mautic sight has stayed the same, however the Wordpress site has changed.

I am wondering if this is the issue although I do not think so.

This is the scenario:
In the original example mautic was on and website was on
In new setup mautic is on and new website is on