Mautic Community Forums

Opens Email Not Getting Tracked

Hi guys. I need your help troubleshooting something with my campaign.



I was just wondering what could be the reason why Mautic is not tracking my Opens Email in Campaigns.



Everything in my campaign has been tracked okay so far (>>>example page hits, form submission, etc.<<<) except for the last part wherein I sent the user a thank you email > if user opens thank you email > add 5 points… that’s it. This last 2 part of my campaign - if user opens thank you email > add 5 points - is not getting tracked by Mautic.



I used a test email, one which I never used before, and when that email arrived, I opened it. So I was expecting that mautic would report this in my Manage Campaigns section but it’s saying Opens email 0 % and Adjust lead points 0 %.



Hope you guys could give an input on this… am I missing something here? Thanks in advance!

Hi guys. I need your help troubleshooting something with my campaign.

I was just wondering what could be the reason why Mautic is not tracking my Opens Email in Campaigns.

Everything in my campaign has been tracked okay so far (>>>example page hits, form submission, etc.<<<) except for the last part wherein I sent the user a thank you email > if user opens thank you email > add 5 points… that’s it. This last 2 part of my campaign - if user opens thank you email > add 5 points - is not getting tracked by Mautic.

I used a test email, one which I never used before, and when that email arrived, I opened it. So I was expecting that mautic would report this in my Manage Campaigns section but it’s saying Opens email 0 % and Adjust lead points 0 %.

Hope you guys could give an input on this… am I missing something here? Thanks in advance!

I think if the recipients mail client does not automatically download images, Mautic is unable to track the open.

Hi @davidjb.

I am using gmail for testings. Can you please explain what you meant by “if the recipients mail client does not automatically download images”?

FF.UP:

@davidjb, I think you are referring to this:

I did some more testings and it is true, the mail client (in my test it’s Gmail) does not automatically download images, so I had to click on “display images below” in order for Mautic Open Email tracking to work.

Is there a workaround on this? It would be nice if people don’t need to click that “display images below” link in order for the tracking to work, as I am sure not everybody would click that.

Fuzzboy, I don’t think you can track without an image, not reliably anyway, because javascript is removed by a lot of email clients.

You can add an image that will display even when a user has images turned off by using base64 encoding. This won’t track the open, because it’s not making a server request.

Hi, I have this same problem. I have not found a solution, you have achieved something?

There is no workaround. Email tracking by an image is not 100% accurate, but it’s the best technique there is. All services which tracks email open actions works exactly like that.

That said, I personally prefer to use the Visits a Page action after email sand. That way I know for sure that a lead opened the email and clicked the link in it. Although it also isn’t 100% accurate because someone could configure his browser not to open images or some add blockers also block tracking pixels. Again, there is no way around it.

You could try adding an image (or a couple of images) with compelling alt text, which may get the user to click the “Display images” button.

I usually include a company header/logo so there’s a big empty box at the top of the email if images aren’t allowed.

I’m not sure if GMail remembers that you’ve allowed images for a particular sender, though.