Mautic Community Forums

Parse error

Hello , i get the following error when trying to run mautic installation on shared hostgator account. Please support on the issue. There was a recommendation in other thread to upgrade the PHP. I am not sure if such upgrade may result something unexpected on my main website. Any support here will help. I can also try to install it on my staging subdomain. but i am not sure if the PHP for the subdomain can be upgraded independantly from main domain.



Parse error: syntax error, unexpected ‘.’, expecting ‘&’ or variable (T_VARIABLE) in /home4/telecoml/public_html/mautic/app/bundles/CoreBundle/ErrorHandler/ErrorHandler.php on line 584

Hello , i get the following error when trying to run mautic installation on shared hostgator account. Please support on the issue. There was a recommendation in other thread to upgrade the PHP. I am not sure if such upgrade may result something unexpected on my main website. Any support here will help. I can also try to install it on my staging subdomain. but i am not sure if the PHP for the subdomain can be upgraded independantly from main domain.

Parse error: syntax error, unexpected ‘.’, expecting ‘&’ or variable (T_VARIABLE) in /home4/telecoml/public_html/mautic/app/bundles/CoreBundle/ErrorHandler/ErrorHandler.php on line 584

Hello , i just updated by PHP to version 7.0, but still the same problem persists.

Any thoughts please !

ok , i SSH into the webhost, and used CLI, found out that the version i am running for PHP is 5.6.30

Kindly advise as it seems the CLI does not confirm to the requirements for PHP.


PHP 5.6.30 (cli) (built: Mar 27 2017 11:48:20)
Copyright © 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.5, Copyright © 2002-2016, by ionCube Ltd.
with Zend Guard Loader v3.3, Copyright © 1998-2014, by Zend Technologies