Mautic Community Forums

Please wait on forms

Hi to everyone.

Forms are stucked on “Please Wait” and no actions such as redirect or show messages works.

We’ve read some information about it but till now no possible to solve.

We’ve tried using http or https, automatic scripts and manual scripts, deleted caches, etc… and nothing works.



Mautic version: 2.8.2



¿Any suggestion about it?



Thanks in advance for ur indications

Hi to everyone.
Forms are stucked on “Please Wait” and no actions such as redirect or show messages works.
We’ve read some information about it but till now no possible to solve.
We’ve tried using http or https, automatic scripts and manual scripts, deleted caches, etc… and nothing works.

Mautic version: 2.8.2

¿Any suggestion about it?

Thanks in advance for ur indications

Have you tried Rebuild forms?

Yes. We do

I had the same issue using forms in my Wordpress site using the Mautic plugin and forms shortcode. While the campaign fired as expected the page locked and said “waiting” I ended up pasting the form’s HTML code on the page and everything worked as expected.

@jdwees. We finally have solved ed this issue upgrading to new version of Mautic and creating again the forms. Thanks for your answer. :slight_smile:

All of my forms are stuck on Please ait… The form data is submitted, but the user just sees “Please Wait”… the redirect and the messages do not show or work… I have updated to the latest version, cleared cache, and still not working… please help.

I think you need to clear cache. Try submitting the form using incognito.

@jwldub Try to re-create the form after upgrading. In our case all forms with this problem remains with same problem after the upgrade. The only solution we’ve found has been build the forms again…

i have the exact same problem as @jwldub and @Salvador Vilalta
re-creating the forms didn’t help though… does anyone know how to fix this?

Re-creating the forms did not help … the problem remains

Same. On the current version. Cleared Cache. Created new forms

http://www.padtinc.com/mautic/testform

I solved the “Please wait” hanging issue by adding ‘www’ to the form URL on the form html code.

I set the action parameter (action="https://MYSITE.com/m…) to action="https://www.MYSITE.com/m

I changed this code:

<form autocomplete="false" role="form" method="post" action="https://MYSITE.com/m/form/submit?formId=25" id="mauticform_mmfthinklikeamfguru" data-mautic-form="mmfthinklikeamfguru" enctype="multipart/form-data">

by this one:

<form autocomplete="false" role="form" method="post" action="https://www.MYSITE.com/m/form/submit?formId=25" id="mauticform_mmfthinklikeamfguru" data-mautic-form="mmfthinklikeamfguru" enctype="multipart/form-data">