Post results to another form not working, nothing sent

Hi there,

I have the last version of Mautic.

I made a Mautic form using the action Post Results to another form. And I cannot get any data that is sent…

I tried to create a request bin (with pipedream) to check how the datas are structured. here are the results:

So at this point I’m happy to see that’s pipedream is getting a response from my form. But when I change the url to my PHP file, I receive and empty array… nothing shows up…

I cannot get any data…

can someone please help??? thanks a lot

In order to debug this better, could you print_r the whole $data?

Hi there thanks for your reply, I tried but nothing showed up… Array is empty… enven tried to print_r $_POST and it’s the same, nothing…

What is your php file location? Can it be that it is blocked by htaccess?

I’m using a subdomain for my personnal script => location of my form => where I need Mautic to send the datas

I didn’t create the htaccess file at the moment, should I try?

I meant, maybe Mautic blocks it.
If you have a tool like Postman, you can simulate the form post and see if something really arrives.

Hi Joeyk,

Do you mind to explain further as I am facing the same issue here.

My installation detail as below:

Mautic Version: 4.2.0
PHP Version 7.4.28
System : Linux.x86_64
Build Date:Feb 23 2022 12:53:00
Database info
Property|Value : |Version|5.7.37-cll-lve| Doctrine driver|mysqli|

My form in version 3.3.5 can do the post method to send result to another form (where i integrate my lead generation to my Mautic as well as Zoom) for seamless registration process for my lead.

Hi, sorry @stleong I don’t understand what you have issue with. Could you plz ellaborate?

I had a form embedded to landing page hosted by Groovepages. I was using the form to send a registration to Mautic, at the same time, I utilize the “Action” function in the form to “Send Result to another Form” for Zoom Registration. This was working with version 3.3.5, but not in Version 4.2

I recently had a server migration of my domain, and moving to the new hosting server. The latest cPanel allow me to install Mautic Version4.2. The installation was successful, but a lot of issue occurred. This has forced me to revert back to Version 3.3.5. And now the function of sending result to another form for version 3.3.5 also not working.

How can I debug this? As you were suggesting to use Postman to simulate the form post and see if something really arrives.

ok, i got the response for the POSTMAN.

However, the dataset that I posted is very different from what I get in POSTMAN



    <p>HO HO HO<p>





                        <?xml version="1.0" encoding="UTF-8" standalone="yes"?>


                            <message>Validation Failed.</message>



                                <message>Missing field.</message>




                                <message>Missing field.</message>



From the dataset above, I see the date of execution is correct, but the email and the mobile number that I key in is different from what I got from POSTMAN.

What seems to be wrong here?

Please allow me to re-iterate what I am facing.

This is my landing page, with the embedded MauticForm

This is my dataset that I tested, and managed to go into Mautic.

as you can see, I never use as the email, reason behind this is if I am using it definitely will give me the error message. Because my zoom account is registered with and Zoom prohibit host to register into the Zoom event.

I can’t further help you with this, maybe a coder can chime in.