Prevent tracking of emails

I’m trying to avoid tracking email copies.

It works like this, for some clients we maintain a copy of all emails we send.

The problem is ofc that if we open those messages, we affect the open rate. I have tried to block the IP, but that doesn’t seem to work.

Is that supposed to work (Settings/System Settings/List of IPs to not track contacts with (one per line)) that way?

Or do I need to find another way?

Could you plz be more specific? What does it mean - “tracking copies”?

Sorry, so we maintain a copy of all emails that we send for some clients.

Basically, we just BCC a mailbox to keep records.

Let me test something…

Hi, just tested.
The recipient AND bcc will get an identical emails. It means, that Mautic doesn’t know which one was opened.
You might want to block automatic image opening from outlook as a workaround.

Plz note, that emails will be preserved in Mautic, by clicking here you’ll see the exact copy of that email:

Thanks, that’s actually how we do it today (with Outlook).

I need to send BCC so that the client(s) get copies, it’s a requirement they have.

But the setting in Settings/System Settings/List of IPs to not track contacts with (one per line), what tracking does it prevent (if it doesn’t prevent tacking email)?

I can ofc have a dev hardcode some IP’s that should be tracked, do you know if this has been done before?


Bumping this because I really cant figure it out.

So, every email that goes out have a BCC.

That email is being read in Outlook Desktop, a machine that have IP:

My settings in Mautic:

But, if I read the email in Outlook (that is, download images), I get this:

It just doesn’t make sense to me.

Any ideas?

If this is a bug (or if I have misunderstood the feature), where in Mautic is the open “counted”? Then I can just script it to ignore certain IPs.

The easiest would be if you would log in as admin to Mautic from that computer. Then you are simply not counted for email and page opens / clicks.

Thanks @joeyk , that doesnt fit our workflow. but is this a bug or does the “non track” function in Mautic work some other way?

I don’t think this is a bug, but I understand that it doesn’t fit your workflow.
The open is registered, because there is an open :slight_smile:
Mautic can’t tell the difference between opening the same email with the same IP address by 2 different entities.
I think blocking tracking IP refers to page visits.

Thanks @joeyk , then it behaves as it should (if it’s just for page visits).

Do you know what module or function in Mautic is responsible for couting “opens”? I need to build a “filter”.

Hi, I can see you posted this on Upwork…
I think you’ll get some people there who won’t understand what you want :slight_smile:
I took another look at the problem. In my opinion you could block the IP on the webserver level.
What happens if you change your apache settings by blocking just that one IP:

Based on:

deny from

Let me know how that worked out.

Hi @joeyk , I have put that o Upwork several times, nobody understands :slight_smile: .

Well, I dont want to block, I want the images that I have in the email to download, but, the open not to count.

We view a copy of every single email that goes out (requirement from a client), and it would be good to be able to see the whole thing, and not just without images.

Would be easier to build a page that displays all sent emails…

Maybe that’s the way to go, lets’s see if I can figure it out. Thanks for your support.