Problem upgrading to Mautic 5.03

Your software
My Mautic version is: 5.03
My PHP version is:8.1
My Database type and version is:

Your problem
My problem is:
I tried to update Mautic to the latest version via SSH.
The command “php bin/console mautic:update:apply” worked fine.
But when I put “php bin/console mautic:update:apply --finish”
I got the following error: "In FileLoader.php line 224:

Expected to find class “MauticPlugin\MauticRssToEmailBundle\vendor\autoload.
" in file “/home/mk.castillapropiedades.com.ar/public_html/plugins/MauticRs
sToEmailBundle/vendor/autoload.php” while importing services from resource
“/home/mk.castillapropiedades.com.ar/public_html/plugins/MauticRssToEmailBu
ndle”, but it was not found! Check the namespace prefix used with the resource.”

And from that moment on Mautic didn’t work anymore. I get this when I try to log in: “The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.”

Does anyone know how to solve this problem?

These errors are showing in the log:

Steps I have tried to fix the problem:

Did you check if the Plugin MauticRssToEmailBundle is Mautic 5 compatible? You can move the Bundle from your Plugin folder to somewhere outside Mautic, clear the cache and try to access Mautic. If you can access it, the Plugin needs an update.

Thanks alexhammer. I moved the MauticRssToEmailBundle folder out of Mautic. I cleared the cache. And when I try to log into Mautic it tells me this: “The “app/bundles/CoreBundle/Resources/views/Offline” directory does not exist (”/usr/local/lsws/lsphp80/bin/app/bundles/CoreBundle/Resources/views/Offline")."

I solved the problem. I moved the entire plugin folder out of Mautic and downloaded Mautic from Mautic.org. I unzipped the plugin folder and uploaded it to mautic via FTP. I cleared the cache and Eureka. Mautic is working again with the latest version.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.