Mautic update 3.3.5 to 4.0.0 failed

Your software
My Mautic version is: 3.3.5
My PHP version is: 7.4.32
My Database type and version is: 5.7.33

Your problem
My problem is:
Hi !

We currently have Mautic in version 3.2.5.
We would like to upgrade to the latest version 4.4.5.
(I am aware that I will have to update PHP afterwards)
To do this, I go through the updates one by one (3.2.5 - 3.3.0 - 3.3.5 - 4.0.0 etc).
Unfortunately, when I go from 3.3.5 to 4.0.0, I get the following error.
For information, I use the following commands:
php bin/console mautic:update:apply --update-package=/var/www/html/mautic/
and then
php bin/console mautic:update:apply --update-package=/var/www/html/mautic/ --finish
All the rights on the files are correct.

Hope you can help me !

These errors are showing in the log:
In FileLoader.php line 208:
Expected to find class “Mautic\LeadBundle\Command\MergeIp” in file “/var/www/html/mautic/app/bundles/LeadBundle/Command/MergeIp.php” while importing services from resource “…/bundles//Command/”, but it was not found! Check the namespace prefix used with the resource.

Steps I have tried to fix the problem:

  • Find FileLoader.php
  • If i move the file, it’s okay but don’t think this is the solution…

Hi guys !

Any news ? :frowning:


Hey there.

I recently upgraded our version of mautic from v3.3.5 to latest mautic v 4.4.5 and it only took me roughly 30mins.

my advice. first try to go from 3.3.5 to latest mautic which is 4.4.5, I only had one error that resolved it self when i ran mautic:update:apply --finish which was a final step for me.

Hey !

Try your methods, unfortunately, not working…
I finally found…
The error file had the wrong name “MergeIP” (I don’t understand where this can come from) the class inside this file is called “MergIPCommand”
So the file should be called “MergeIPCommand.php”
Then no problem for the upgrade …

I hope this will help other people

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.