Mautic Community Forums

Problem with additional fields in campaigns (on field update)

Hey,



i hope i am right here. I have a problem and i dont know if its a problem of how i use it or and otherwise problem.

I create an campaign based on segments (named: yoga), it use an filter tag.

Next i add an additional field level. (is an numeric, from 0 - 5). Every Contact can update get into an higher level (we update the level via api). Default value is 0.



our campaign looks something like this:

ajxv5s.jpg



As you can see the user get an Welcome Email.

First they also get triggered with 2 E-Mails (wait 10 days, wait 15 days).

This works fine, the campaign trigger, sets the trigger points etc.

But when we update now the level field to 1 and execute the trigger command, nothing changes. It should change to Level 1 actions (3 E-Mails, first immediately, second after 10 days, third after 15 days).



is there something i do wrong?



regards and thx


Hey,

i hope i am right here. I have a problem and i dont know if its a problem of how i use it or and otherwise problem.
I create an campaign based on segments (named: yoga), it use an filter tag.
Next i add an additional field level. (is an numeric, from 0 - 5). Every Contact can update get into an higher level (we update the level via api). Default value is 0.

our campaign looks something like this:

As you can see the user get an Welcome Email.
First they also get triggered with 2 E-Mails (wait 10 days, wait 15 days).
This works fine, the campaign trigger, sets the trigger points etc.
But when we update now the level field to 1 and execute the trigger command, nothing changes. It should change to Level 1 actions (3 E-Mails, first immediately, second after 10 days, third after 15 days).

is there something i do wrong?

regards and thx