Mautic Community Forums

Problem with FontAwesome after update

Hello,



I have recently update Mautic through the app.

After a successful update process, i notice all icons have blow away:

http://imgur.com/3Obkb1X



I guess it could be a permission issue.



It is quite annoying. Furthmore i would like to try some third party integration like mailchimp and i don’t find the way anymore.

It’s my first mautic test in production and i would to go into a little deeper.



Thank you advance for any help.

jb

Hello,

I have recently update Mautic through the app.
After a successful update process, i notice all icons have blow away:
http://imgur.com/3Obkb1X

I guess it could be a permission issue.

It is quite annoying. Furthmore i would like to try some third party integration like mailchimp and i don’t find the way anymore.
It’s my first mautic test in production and i would to go into a little deeper.

Thank you advance for any help.
jb

Hi, the FontAwesome assets are not loading for some reason. You may want to inspect more details with Dev tools (press F12). Hard to say what could be wrong without it.

Mailchimp plugin is actually pre-installed in the core Mautic. Go to admin menu (the cog icon in the top right corner) and select plugins.

Hello,

Thank you for your reply.

About FontAwesome, the file are on 404 error:
http://automation.soapoperator.com/app/bundles/CoreBundle/Assets/css/libraries/font-awesome/fonts/fontawesome-webfont.woff2?v=4.3.0

HTTP/1.1 404 Not Found Server: nginx Content-Type: text/html; charset=UTF-8 Transfer-Encoding: chunked Connection: keep-alive Vary: Accept-Encoding X-Powered-By: PHP/5.5.9-1ubuntu4.14 Set-Cookie: mautic_session_name=424efa1489bcef871228c8ae108dbd7c; path=/; secure; httponly mautic_session_name=424efa1489bcef871228c8ae108dbd7c; path=/; secure; httponly Cache-Control: no-cache Date: Wed, 20 Jan 2016 19:56:20 GMT

I try to change the permission without success:

root@server:/usr/share/nginx/html/automation.soapoperator.com/htdocs/app/bundl es/CoreBundle/Assets/css/libraries/font-awesome/fonts# ls -l total 708 -rwxrwxrwx 1 www-data www-data 93888 Jan 15 23:38 FontAwesome.otf -rwxrwxrwx 1 www-data www-data 60767 Jan 15 23:38 fontawesome-webfont.eot -rwxrwxrwx 1 www-data www-data 313398 Jan 15 23:38 fontawesome-webfont.svg -rwxrwxrwx 1 www-data www-data 122092 Jan 15 23:38 fontawesome-webfont.ttf -rwxrwxrwx 1 www-data www-data 71508 Jan 15 23:38 fontawesome-webfont.woff -rwxrwxrwx 1 www-data www-data 56780 Jan 15 23:38 fontawesome-webfont.woff2

About Mailchimp, without FontAwesome, the button was hide. I try to enabled it but until now, its a mess between API Key, account id, account password. And it doesn’t work for now.

Bye,
jB

I have checked in system info…

I get an error for the permission:
/srv/data/web/vhosts/automation.soapoperator.com/htdocs/app/…/media/files Non accessible en écriture
It’s normal because the app is not install here?

And in the log:
[2016-01-21 05:05:08] mautic.ERROR: Uncaught PHP Exception SymfonyComponentHttpKernelExceptionNotFoundHttpException: “URL demandée introuvable : /app/bundles/CoreBundle/Assets/css/libraries/font-awesome/fonts/fontawesome-webfont.woff2?v=4.3.0” at /usr/share/nginx/html/automation.soapoperator.com/htdocs/app/bundles/CoreBundle/Controller/CommonController.php line 352 {“exception”:"[object] (Symfony\Component\HttpKernel\Exception\NotFoundHttpException(code: 0): URL demandée introuvable : /app/bundles/CoreBundle/Assets/css/libraries/font-awesome/fonts/fontawesome-webfont.woff2?v=4.3.0 at /usr/share/nginx/html/automation.soapoperator.com/htdocs/app/bundles/CoreBundle/Controller/CommonController.php:352)"} []

I try to make some config change. Now:

The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

And i don’t see any error about it in the log (/app/logs).
Do i have to reinstall or upgrade the app?

Try to revert the config change you’ve made, clear cache and Mautic should run again.

The fontawesome 404 error is something in your ngnix config I guess. I’m not familiar with ngnix that much. Maybe ask in some forum where are some sysadmins.

Hello,

You perfectly right, i solve the font issue by adding to the host config:

[code]
server {

[…]

location ~* ^.+.(eot|ttf|woff|woff2)$ {
add_header Access-Control-Allow-Origin *; # that solve
expires 1M;
access_log off;
add_header Cache-Control “public”;
}

}[/code]

This problem is solved.
Not Mailchimp integration with https://www.mautic.org/docs/plugins/mailchimp.html
I get a 404 in the pop-over when i try to authorize the connexion:
https://login.mailchimp.com/oauth2/authorize?client_id=xxx@xxx.com&response_type=code&redirect_uri=https%3A%2F%2Fautomation.soapoperator.com%2Fs%2Fplugins%2Fintegrations%2Fauthcallback%2FMailchimp&state=xxx

Thank you for your help.
jB

That may be because the username is not an email address.

https://www.mautic.org/docs/plugins/mailchimp.html

Connexion is pefect after i create an app.
Now i don’t see my subscribers list… Work in progress!