Mautic Community Forums

Problems viewing an email in browser

Hi!,



We’re using mautic v2.2.2-dev on a self-hosted server, and are having an issue when sending emails to contacts:

If you click on the ‘View this email in your browser’ link at the bottom of the email, you get the usual error:

The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

System administrators, check server logs for errors.



After some tests, we’ve found that if you have opened a session on the mautic, and you click the same link, the page is opened correctly.

Are there any way to fix this? I mean, some kind of anonymous access to the pages showing emails, or some other workaround?



Thanks in advance.



Best regards,

Hi!,

We’re using mautic v2.2.2-dev on a self-hosted server, and are having an issue when sending emails to contacts:
If you click on the ‘View this email in your browser’ link at the bottom of the email, you get the usual error:
The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.
System administrators, check server logs for errors.

After some tests, we’ve found that if you have opened a session on the mautic, and you click the same link, the page is opened correctly.
Are there any way to fix this? I mean, some kind of anonymous access to the pages showing emails, or some other workaround?

Thanks in advance.

Best regards,

Sorry, I forgot to add this information to my previous post. When you click on the link at the email, the following is shown in the logs:

[2016-11-17 10:05:22] mautic.ERROR: Error: Call to a member function getId() on null - in file /var/www/html/mautic/app/bundles/EmailBundle/Helper/PointEventHelper.php - at line 30 [] []

Best regards,