Problems with OAUTH2 in Mautic 4.4.9 - no Access Token, no Refresh Token generated

Your software
My Mautic version is: 4.4.9
My PHP version is: 8.0.29
My Database type and version is: 10.9.7-MariaDB-1:10.9.7+maria~ubu2004

Your problem
My problem is:
I tried to connect WP-Fusion Lite to Mautic using the api and OAUTH2.
I followed the manual how to do it. I got forwarded from the WP site to Mautic to log in. Log in worked without problems and redirect back to page was succesful. But no Access Tokens nor Refresh Token were transferred from Mautic.
I tried the same with, but no Access Token nor Refresh Token were transmitted back. The object is empty.
Furthermore, I have installed a new fresh Mautic on a new server (docker) to test it and I had the same problem.

I had a look into the database, no Access Token nor Refresh Token have been saved in the database.

All folders and files are writable.

These errors are showing in the log:
No errors in the log.

Steps I have tried to fix the problem:
Installed a blank new Mautic 4.4.9 on a new server and tested it. Problem persists.

Any help appreciated!


What guide did you follow? Oauth client id and secret are generated under Settings Wheel → API Credentials.

We found the issue. The infrastructure is a little more complex than usual.
it was just an internally used SSL certificate on the Mautic server (that is behind Cloudflare) which wasn’t trusted by WP-Fusion connecting directly from the internal network.


1 Like