Mautic Community Forums

This form is no longer available

Your software
My Mautic version is: latest version

Your problem
My problem is: I have tried many many configurations to simply post data from a form using react to Mautic. I have CORS turned off and turned on, I have sent form parameters in every which way and I always get “This form is no longer available” but I am staring at the form in the dashboard which has one single field. The form submission works fine when using the js script copy/paste from the instructions in the dashboard.

I am using gatsby and react so was wondering if there is any trick that I am missing here for just posting data: I get the following url back in the console:

" http://localhost:8000/my-blog-post/?mauticError=This%20form%20is%20no%20longer%20available."

I have been working on this for two days and wasted several hours trying to simply post data to mautic. I am concerned at this point that this is not possible or something is terribly wrong.

I am seeing the following in the apache logs:
“Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.”

I am curious if something in the mautic redirect is doing something odd. I have “stay on form” selected for my form so I cannot imagine what this is redirecting.

At this point any hint of something that could possibly be happening would be appreciated.

These errors are showing in the log:

Steps I have tried to fix the problem:

is there any solution?
I am stuck in with the same problem

Hi,
This error happens if you have the wrong format :slight_smile:
Here is a working example, maybe you can spot your mistake?

"
@joeyk what can be the error?"

worked @joeyk thanks a lot.
mauticform in the fields."
Thanks again