Trouble installing custom themes: "Unable to write in the "/app/themes" directory."

Mautic version is: 5.1.23
PHP version is: 8.1.27
Database type and version is: 10.6.16-MariaDB-0ubuntu0.22.04.1

My problem is:

I cannot install new themes in No matter what .zip theme file I try to install (new, from online, following any tutorial…), I get the same error “Unable to write in the “/app/themes” directory.”. Same happened to my co-workers who I asked to try on their accounts. We all have administrator roles, which should be ‘full system access’.

Screenshot 2024-02-20 at 9.46.40

Steps I have tried to fix the problem:

I have tried uploading various different .zip theme files, but the result is always the same. I have tried searching through the internet including these forums for an answer.

I was simply given an account to our Mautic project with the task of creating a custom theme for our emails, and I am stuck with this installation blocker. I figured while I continue to try and fix it I could also post here in case someone already knows what the issue could be, and is willing to help

themes directory needs to be writable by webserver user (usually www-data):

chown -R www-data:root themes

Thank you a lot for the reply mzagmajster! We are now happily theming.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.