Trying to publish plugin to marketplace


I am following these instructions: Listing a Plugin in the Marketplace — Mautic Developer Documentation 3.0.0 documentation

to prepare plugin for marketplace. I am running into issues when I am trying to run the composer install (just to see if composer install passes).

I run:

php7.4 /usr/local/bin/composer install

and I get the following error:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - mautic/core-lib[4.0.0-alpha1, ..., 4.x-dev] require friendsofsymfony/oauth-server-bundle dev-doctrine-fix -> found friendsofsymfony/oauth-server-bundle[dev-master, 1.0.0, ..., 1.7.x-dev, 2.0.0-alpha.0, 2.0.x-dev (alias of dev-master)] but it does not match the constraint.
    - Root composer.json requires mautic/core-lib ^4.0 -> satisfiable by mautic/core-lib[4.0.0-alpha1, ..., 4.x-dev].

my composer.json file is as follows:

    "name": "mautic/my-bundle",
    "description": "My bundle",
    "type": "mautic-plugin",
    "keywords": [
    "extra": {
        "install-directory-name": "MyBundle"
    "scripts": {
        "lint": "vendor/bin/parallel-lint --exclude ./vendor .",
        "checkcs": "php-cs-fixer fix --config=./.php_cs.dist.php --diff --dry-run",
        "fixcs": "php-cs-fixer fix --config=./.php_cs.dist.php"
    "minimum-stability": "dev",
    "require": {
        "php": ">=7.4.0 <8.1",
        "mautic/core-lib": "^4.0"
    "require-dev": {
        "php-parallel-lint/php-parallel-lint": "^1.3",
        "friendsofphp/php-cs-fixer": "2.19.0"

I even tried removing dev packages all together, changing min. stability etc. but I am stuck on this step. I can see that other plugins require mautic/core-lib so what am I missing.

Thanks for any pointers

Can you check this out.