Unable to create a mail (3.2.5)

Your software
My Mautic version is: 3.2.5
My PHP version is: 7.4.3
My Database type and version is: mariaDB 10.3.25

Your problem
My problem is:
I had installed mautic 2-3 days ago. I performed some tests and everything was ok. The next day, when I tried to send an mail, nothing happened when I clicked on “new” button. I restarted my server but nothing changed. Since I hadn’t import any contacts I decided to re install mautic.
When I finished everything was ok. I could send email too.
Today I have the same problem. If I click on “new” to create an email, nothing happens
What is going on?
It works only the first day? I haven’t changed anything
On the same server I have installed suitecrm and works fine

These errors are showing in the log:
No errors
But i get an HTTP ERROR 500 when I log in to my account. I press reload and I am in.

Steps I have tried to fix the problem:
I re installed mautic

Do you have wordpress installed? Any firewall software on it?

No, nothing. No firewall. Only the basics (apache, mariaDB, php)
It is a vps (hetzner) with ubuntu 20.04.
I have installed only suitecrm and mautic

I am going to install mautic now to another vps I have with ubuntu 18.04 to see what will happen

I have Mautic on a hetzner VPS too, Ubuntu 20.04, with ISPConfig. Works fine. It is not a hetzner problem.

Indeed, I think it has to do with server’s configuration.
I have created an other 2 instances, this time with ubuntu 18.04, php 7.4.16 and mariaDB 10.4.18, mautic 3.3.2.
Exactly the same problem on both servers. The next day i could not click email
I tried one instance on digital ocean with same specifications where I transferred the installation of mautic.
It worked fine for 2 days. Then, the same problem, I could not create an email. I tried to type the url (https://Mydomain/s/emails/new) and i got http error 500.
The problem was solved after setting the permissions and ownership of mautic folder.

sudo chown -R www-data:www-data /var/www/mautic/
sudo chmod -R 755 /var/www/mautic/

Now I am waiting to see what will happen in 2-3 days.
I don’t understand what I am doing wrong.

Hello Beethoven !

I have a comparable problem with emails creating.
Have you solved your own ?

Thanks in advance.

OK !
It was the firewall.
After desactivating it, email creation is working !
Thanks, Joeyk !

I have also set the firewall to authorize operations coming from my IP.
So I do not need to desactivate completely the firewall.

In my case it wasn’t the firewall since I haven’t set up a firewall.
I set permissions/ownership of the folder and it works fine.
I am waiting to see if the problem occurs again.