Mautic Community Forums

Unable to Edit Certain Contacts

running the latest version of mautic-3 and I am unable to edit certain contacts.

There is nothing in the mautic.error log.

Inside the console I am seeing this:
GET … /s/contacts/edit/591?_=1631617585421&mauticUserLastActive=16&mauticLastNotificationId= 500 (Internal Server Error)

send @ libraries.js?vb72a10f7:766
ajax @ libraries.js?vb72a10f7:744
Mautic.loadContent @ app.js?vb72a10f7:40
Mautic.ajaxifyLink @ app.js?vb72a10f7:103
(anonymous) @ app.js?vb72a10f7:88
dispatch @ libraries.js?vb72a10f7:465
elemData.handle @ libraries.js?vb72a10f7:451

and in the system log I get this:
[2021-09-14 14:06:41] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Form\Exception\TransformationFailedException: “Unable to transform data for property path “pt_update_date”: Unexpected data found.” at /var/www/mautic/vendor/symfony/form/Form.php line 1034 {“exception”:"[object] (Symfony\Component\Form\Exception\TransformationFailedException(code: 0): Unable to transform data for property path “pt_update_date”: Unexpected data found. at /var/www/mautic/vendor/symfony/form/Form.php:1034, Symfony\Component\Form\Exception\TransformationFailedException(code: 0): Unexpected data found. at /var/www/mautic/vendor/symfony/form/Extension/Core/DataTransformer/DateTimeToStringTransformer.php:128)"} [

I have tried chowning the mautic directory.
I have updated /update/schema

Any ideas ?

I solved this it was an issue with a number of date fields that had incorrect values in them.

The clue was sitting in the system logs