Update from 4.4.12 to 5.1.0 fails

Your software
My Mautic version is: 4.4.12
My PHP version is: 8.0.30
My Database type and version is: MySQL 8.0.37

Your problem
My problem is:
Update from 4.4.12 as per documentation How to update Mautic — Mautic Documentation 0.1 documentation does not work and shows the following messages on the command line:

composer update --with-all-dependencies
Loading composer repositories with package information
Updating dependencies                                 
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires mautic/core-composer-scaffold 5.x-dev, 
    found mautic/core-composer-scaffold[dev-RCheesley-patch-1, 3.x-dev, 4.x-dev] 
    but it does not match the constraint.
  Problem 2
    - Root composer.json requires mautic/core-project-message 5.x-dev, 
    found mautic/core-project-message[3.x-dev, 4.x-dev] 
    but it does not match the constraint.
  Problem 3
    - Root composer.json requires mautic/plugin-citrix 5.1.0, 
    found mautic/plugin-citrix[dev-gitsplit-action-debug, dev-main, dev-features, dev-4.4.8-release, 
    dev-4.4.9-release, 1.0, 3.x-dev, 4.0.0-alpha1, ..., 4.x-dev, 5.x-dev] 
    but it does not match the constraint.
  Problem 4
    - Root composer.json requires mautic/theme-coffee 5.1.0, 
    found mautic/theme-coffee[dev-gitsplit-action-debug, dev-features, dev-main, dev-4.4.8-release, 
    dev-4.4.9-release, 4.0.0-rc, ..., 4.x-dev, 5.0.0-alpha, ..., 5.x-dev] 
    but it does not match the constraint.
  Problem 5
    - Root composer.json requires mautic/theme-mauve 5.1.0, 
    found mautic/theme-mauve[dev-gitsplit-action-debug, dev-features, dev-main, dev-4.4.8-release, 
    dev-4.4.9-release, 4.0.0-rc, ..., 4.x-dev, 5.0.0-alpha, ..., 5.x-dev] 
    but it does not match the constraint.
  Problem 6
    - Root composer.json requires mautic/theme-nature 5.1.0, 
    found mautic/theme-nature[dev-gitsplit-action-debug, dev-main, dev-features, dev-4.4.8-release, 
    dev-4.4.9-release, 4.0.0-alpha1, ..., 4.x-dev, 5.0.0-alpha, ..., 5.x-dev] 
    but it does not match the constraint.
  Problem 7
    - Root composer.json requires mautic/core-lib 5.1.0 -> satisfiable by mautic/core-lib[5.1.0].
    - mautic/core-lib 5.1.0 requires php ~8.0 -> your php version (7.4.33) does not satisfy that requirement.
  Problem 8
    - mautic/core-lib 5.1.0 requires php ~8.0 -> your php version (7.4.33) does not satisfy that requirement.
    - mautic/theme-vibrant 5.1.0 requires mautic/core-lib ^5.0 -> satisfiable by mautic/core-lib[5.1.0].
    - Root composer.json requires mautic/theme-vibrant 5.1.0 -> satisfiable by mautic/theme-vibrant[5.1.0].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages 
currently locked to specific versions.

Strangely, the composer command shows I run PHP 7.4.33 which is not correct. I run Mautic with PHP 8.0.30. That is what Mautic even shows in the System Info Menu.

These errors are showing in the log:

No log entries, not even in PHP error log.

Steps I have tried to fix the problem:

Only tried what is mentioned in the documentation. Unfortunately, the documentation does not state anything about updating from 4.4.12 to 5.1.0.

What do I need to do to update from 4.4.12 to 5.1.0?
Any help appreciated. Thanks!

Personally, I’m not sold on Mautic 5 yet. What’s the draw for you @stemautic88 ?

@entrepositive Good question. Curiosity mostly. I run Mautic on several websites and wanted to try 5.1.0 with the one that has the lowest traffic. But as it seems, the update process from 4 to 5 is not yet very well documented. At least, I wasn’t able to figure out what to do. I’m not a developer, just a tech-savvy user. Though, I’m pleased when things don’t get too complicated. :wink:

But I’m fine to wait until there is a clear path to update from 4.4.12 to 5.x.