Mautic Community Forums

Update Mautic to 1.1.2

Hi I have 1.1.0 installed on a shared host and according to the notifications I am prompted to upgrade to 1.1.2 - so I go ahead but it keeps saying “Downloading Package” in progress with the spinning icon moving for last 30 mins but no indication what is going on. I dont have shell access and dont want to do a full manual upload if I can help it

Hi I have 1.1.0 installed on a shared host and according to the notifications I am prompted to upgrade to 1.1.2 - so I go ahead but it keeps saying “Downloading Package” in progress with the spinning icon moving for last 30 mins but no indication what is going on. I dont have shell access and dont want to do a full manual upload if I can help it

Hi @azaidi,

It definitely shouldn’t take 30 minutes to download the package :slight_smile: Does it happen every time you try? If you look at app/logs/mautic_prod.php, are there any errors recorded?

Thanks,
Alan

I checked the error log in the root directory and it indicated a memory exhausted error so I changed the max memory limit to 256M now I get an error message Fatal error: Class ‘PDO’ not found in /home/thamesp/public_html/crm2015/vendor/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php on line 155

and I cant login any more

Wondering if somehow PDO got disabled when you modified the memory limit? What was the memory limit set at to begin with? Simply downloading the package shouldn’t have hit the limit I wouldn’t think; unless it was really low.

Look for these in your php.ini:
extension=pdo.so
extension=pdo_mysql.so

Alan

Thanks a lot. Added the

extension=pdo.so
extension=pdo_mysql.so

to my php.ini after increasing the memory limit from what it was before (64M) to 256M. Suddenly the update to 1.1.2 became a snap and now successfully at 1.1.2

Thanks again

Hi, I’m with the same problem, and I’m using GoDaddy (a real shit), well, is there a way to manually update it?

You need to have a quick look at the error logs to confirm you have the same problem I did. Go to your mautic directory and look at error_logs.txt or to the app/logs/mautic_prod.php file. If you see any messages related to memory exhaustion, then you need to create a php.ini file and upload it in your directory with the following:

memory_limit = 256M ;

This should cure the spinning problem. Then if you get an error relating to pdo not being there (check error logs again) then add the following lines to the php.ini previously uploaded:

extension=pdo.so
extension=pdo_mysql.so