Mautic Community Forums

New (first) install - annot add contacts

Your software
My Mautic version is: 2.15.1
My PHP version is: 7.2

Your problem
My problem is:

I just installed Mautic for the first time. I was successful in adding a company, however adding a contact does not work:

Clicking on +New nothing happens except for the blue bar at the top moving.
Clicking on QuickAdd the window opens, I add a name plus email address plus I select the company, click save, however the save does not occur.

Thanks for any input

1 Like

Hi @summer and welcome to the forums!

Are you seeing any errors in your error log (Settings>system info>log)?

Did your install go OK, or did you get any errors in the process?

Installation went without issues. PHP version is 7.2

The log says:

[2019-08-21 12:57:34] mautic.ERROR: PHP Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 67108872 bytes) - in file /DOMAIN/vendor/symfony/intl/Data/Bundle/Reader/BundleEntryReader.php - at line 134
[2019-08-21 12:57:34] mautic.ERROR: Symfony\Component\Debug\Exception\OutOfMemoryException: Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 67108872 bytes) - in file /DOMAIN/vendor/symfony/intl/Data/Bundle/Reader/BundleEntryReader.php - at line 134
[2019-08-21 12:57:34] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\OutOfMemoryException: “Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 67108872 bytes)” at /DOMAIN/vendor/symfony/intl/Data/Bundle/Reader/BundleEntryReader.php line 134 {“exception”:"[object] (Symfony\Component\Debug\Exception\OutOfMemoryException(code: 0): Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 67108872 bytes) at /DOMAIN/vendor/symfony/intl/Data/Bundle/Reader/BundleEntryReader.php:134)"}

Looks like you need to increase the memory available for scripts, as it’s running out of memory.

Thanks. What would be the recommended minimum? (We are talking about php memory, rt?)

Well, I increased the memory limit to 256MB. I still get the same behaviour. Is that normal.

Ok, so I cleared the cache and now am trying to install the 15.2 upgrade in the hopw this will solve the issue.

However after the download and extraction of the package have been completed, the final step “Moving Package Contents” seems to take hours.

It would be sad having to uninstall Mautic and turn to another software, as the basic concept truly appeals to me.

Is there any solution to all of this?

Thanks

@summer

Please follow this

1.Login SSH

2.Go to mautic root where mautic has installed like /var/www/html/Mautic/

3 For Clear cache run this command: php app/console cache:clear OR rm -rf app/cache

4.To check mautic latest version available RUN: php app/console mautic:update:find

5.To update Run: php app/console mautic:update:apply – force

6.Try to run database migrations: php app/console doctrine:migration:migrate

7.Try to update database schema: php app/console doctrine:schema:update --force

8.Run to warm up cache: php app/console cache:warmup

9.To Give permission to cache folder: sudo chmod -R 777 /var/www/html/Mautic/app/cache

10.Clear your browser cache also and you will see your mautic has upgraded

Hi there,

Thanks for your assistance. Again I get a memory issue:

(on running mautic:update)

PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 48399344 bytes) in /home/…server …/vendor/joomla/http/src/Transport/Curl.php on line 222

[Symfony\Component\Debug\Exception\OutOfMemoryException]
Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 48399344 bytes)


I tried 2 times more but now the message is even short:

An error occurred while downloading the update package.

When you changed the memory limit, where did you change it? Sometimes it’s easy to change it in the wrong place so that it doesn’t make the change expected.

There are some issue with Locale.php file in /vendor/symfony/intl/Locale.php

I changed the memory limit on the server of my hosting company.

Shall I remove the existing file?

Thanks

no https://drive.google.com/open?id=1WF2YEEShiiXAeppKb0S34xwE3zw5V9xr Replace with this

Well, I am giving up. I replaced the Locale.php but again get this:

PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 48399344 bytes) in /home/domain/vendor/joomla/http/src/Transport/Curl.php on line 222

[Symfony\Component\Debug\Exception\OutOfMemoryException]
Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 48399344
bytes)

I guess I’ll just wait a few months for further updates and try again.

Thanks anyway for your attempts to help.

Cheers

install php curl extention on your server

Sorry what I meant is which actual php.ini file did you change. Sometimes it is possible to change the wrong one, as often there are several in use - for example the php.ini used in command-line commands can sometimes be different to that used with web-based resources.

Can you share the file path where you made the change to the memory limit, and what you set it to?

Do you have command line access to your server, or are you doing this via the control panel of your hosting provider?

Hello Ruth,

I only changed the memory at my provider’s end. Could you pass me the file path to the php.ini file and what memory setting you recommend? (I have access to my provider with command line as well as their control panel).

Thanks

Hi again,

Here’s a quick vid explaining how to determine what php.ini file is in use, and how to check what the current memory setting is being used: https://youtu.be/v6a8A3x1sKw

Hope that helps!

2 Likes

Thank you Ruth, very kind to make a short video and explain things.

2 Likes