Upgrade M3: Forbidden You don't have permission to access this resource

From Beta 2.16.3 : i got error message Forbidden You don’t have permission to access this resource when i tried to upgrade to M3.

as i updated from 2.16.2 to 2.16.3 without ant issue, i do not understand !

Are they any changes to apply in permission rules ?

I am using last Bitnami image on top of aws

Thank’s in advance

Hi there,

We are unable to support you if you do not provide the information required in the post template.

Please edit your post.

Here is the template:

Your software
My PHP version is :
My MySQL/MariaDB version is (delete as applicable): MySQL/MariaDB version

Updating/Installing Errors
I am (delete as applicable): Installing / Updating
Upgrading/installing via (delete as applicable) : Web / Command Line

These errors are showing in the installer :

These errors are showing in the Mautic log :

These errors are showing in the upgrade_log.txt file (located in the root of your Mautic instance when an upgrade has been attempted - ensure you remove or redact any sensitive data such as domain names in the file path) :

Your problem
My problem is :

Steps I have tried to fix the problem :

Solved :slight_smile

1 / replace Require all denied by Require all granted
2 / Reboot
3 / upgrade to M3
4 / back htaccess.conf to Require all denied
5/ Reboot

  • Apache 2.4+

  • # Deny access via HTTP requests to all PHP files.
  • <FilesMatch "\.php$">
  •     **Require all denied**
  • </FilesMatch>
  • # Except those whitelisted bellow.
  • <FilesMatch "^(index|index_dev|filemanager|upgrade)\.php$">
  •     Require all granted
  • </FilesMatch>