Mautic Community Forums

Upgrade to 2.16.3 said its ok but not working

Your software
My Mautic version is:2.16.3
My PHP version is:7.2

Your problem
My problem is:
Just upgraded using CLI from 2.16.0 to 2.16.3 and Mautic stopped working - I am getting this in the log file

These errors are showing in the log:
mautic.ERROR: PHP Notice: require(): Failed opening required ‘<my_path_here>/public_html/app/cache/prod/doctrine/orm/Proxies/__CG__Mau
ticPluginBundleEntityPlugin.php’ (include_path=’.:/usr/local/php/7.3/7.3.22-dh34/lib/php’) - in file <my_path_here>/public_html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209

Any hints?

First hint: Your php version seems to be 7.3

Yes, tried with 7.3 but the same error getting with 7.2. 7.3 is supported by 2.16.x right?

has been looking for posts with similiat errors with /vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 and found one which suggested to run:
find . -type d -exec chmod 755 {} ;
find . -type f -exec chmod 644 {} ;

not sure if this was that, but now Mautic 2.16.3 is working.

setting appropriate file permissions