Mautic Community Forums

Uploading asset leads to redirect loop and 403

I have an issue when I try to upload a file through Components->Assets->New. This is the error that I get on the page:



01_zpsdbfqetpp.png



I also enabled

Code:
mod_rewrite
logging and found the following message:
Code:
[Tue Feb 14 14:10:20.660824 2017] [rewrite:trace1] [pid 551:tid 139800245827328] mod_rewrite.c(477): [client 151.231.*.***:*****] 151.231.*.*** - - [34.248.***.***/sid#218ad18][rid#7f25ac004980/initial] [perdir /opt/bitnami/apps/suitecrm/htdocs/mautic/] internal redirect with /mautic/index.php [INTERNAL REDIRECT], referer: http://34.248.***.***/mautic/s/assets/new

I also tested the app on http://htaccess.mwl.be/ and got the following result:

02_zps5n3escef.png

So apparently I have a rewrite rule that causes an internal looping redirection. The default `.htaccess` gives 2 suggestions as to what to do in this case, however neither of them worked. The `/htaccess` file:
Code:
RewriteEngine On
RewriteCond %{HTTP:Authorization} .+
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

# Determine the RewriteBase automatically and set it as environment variable.
# If you are using Apache aliases to do mass virtual hosting or installed the
# project in a subdirectory, the base path will be prepended to allow proper
# resolution of the app.php file and to redirect to the correct URI. It will
# work in environments without path prefix as well, providing a safe, one-size
# fits all solution. But as you do not need it in this case, you can comment
# the following 2 lines to eliminate the overhead.
RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::2$
RewriteRule ^(.*) - [E=BASE:%1]

# Redirect to URI without front controller to prevent duplicate content
# (with and without `/app.php`). Only do this redirect on the initial
# rewrite by Apache and not on subsequent cycles. Otherwise we would get an
# endless redirect loop (request -> rewrite to front controller ->
# redirect -> request -> ...).
# So in case you get a "too many redirects" error or you always get redirected
# to the start page because your Apache does not expose the REDIRECT_STATUS
# environment variable, you have 2 choices:
# - disable this feature by commenting the following 2 lines or
# - use Apache >= 2.3.9 and replace all L flags by END flags and remove the
#   following RewriteCond (best solution)
RewriteCond %{ENV:REDIRECT_STATUS} ^$
RewriteRule ^index.php(/(.*)|$) %{ENV:BASE}/$2 [R=301,L]

# If the requested filename exists, simply serve it.
# We only want to let Apache serve files and not directories.
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule .? - [L]

# Rewrite all other queries to the front controller.
RewriteRule .? %{ENV:BASE}/index.php [L]

<IfModule !mod_rewrite.c>

# When mod_rewrite is not available, we instruct a temporary redirect of
# the start page to the front controller explicitly so that the website
# and the generated links can still be used.
RedirectMatch 302 ^(?!/(index.php|index_dev.php|app|addons|plugins|media|upgrade))(/(.*))$ /index.php$2
# RedirectTemp cannot be used instead

# @link https://github.com/mautic/mautic/issues/1504 php_value always_populate_raw_post_data -1

One thing to note: Mautic is running in it's own subdirectory of the web root (
Code:
/mautic
). All other Mautic functionality appears to be working.

Looking forward to any insights or suggestions.

I have an issue when I try to upload a file through Components->Assets->New. This is the error that I get on the page:

I also enabled mod_rewrite logging and found the following message:

[Tue Feb 14 14:10:20.660824 2017] [rewrite:trace1] [pid 551:tid 139800245827328] mod_rewrite.c(477): [client 151.231.*.***:*****] 151.231.*.*** - - [34.248.***.***/sid#218ad18][rid#7f25ac004980/initial] [perdir /opt/bitnami/apps/suitecrm/htdocs/mautic/] internal redirect with /mautic/index.php [INTERNAL REDIRECT], referer: http://34.248.***.***/mautic/s/assets/new

I also tested the app on http://htaccess.mwl.be/ and got the following result:

So apparently I have a rewrite rule that causes an internal looping redirection. The default .htaccess gives 2 suggestions as to what to do in this case, however neither of them worked. The /htaccess file:

<IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{HTTP:Authorization} .+
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    # Determine the RewriteBase automatically and set it as environment variable.
    # If you are using Apache aliases to do mass virtual hosting or installed the
    # project in a subdirectory, the base path will be prepended to allow proper
    # resolution of the app.php file and to redirect to the correct URI. It will
    # work in environments without path prefix as well, providing a safe, one-size
    # fits all solution. But as you do not need it in this case, you can comment
    # the following 2 lines to eliminate the overhead.
    RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::2$
    RewriteRule ^(.*) - [E=BASE:%1]

    # Redirect to URI without front controller to prevent duplicate content
    # (with and without `/app.php`). Only do this redirect on the initial
    # rewrite by Apache and not on subsequent cycles. Otherwise we would get an
    # endless redirect loop (request -> rewrite to front controller ->
    # redirect -> request -> ...).
    # So in case you get a "too many redirects" error or you always get redirected
    # to the start page because your Apache does not expose the REDIRECT_STATUS
    # environment variable, you have 2 choices:
    # - disable this feature by commenting the following 2 lines or
    # - use Apache >= 2.3.9 and replace all L flags by END flags and remove the
    #   following RewriteCond (best solution)
    RewriteCond %{ENV:REDIRECT_STATUS} ^$
    RewriteRule ^index.php(/(.*)|$) %{ENV:BASE}/$2 [R=301,L]

    # If the requested filename exists, simply serve it.
    # We only want to let Apache serve files and not directories.
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule .? - [L]

    # Rewrite all other queries to the front controller.
    RewriteRule .? %{ENV:BASE}/index.php [L]
</IfModule>

<IfModule !mod_rewrite.c>
    <IfModule mod_alias.c>
        # When mod_rewrite is not available, we instruct a temporary redirect of
        # the start page to the front controller explicitly so that the website
        # and the generated links can still be used.
        RedirectMatch 302 ^(?!/(index.php|index_dev.php|app|addons|plugins|media|upgrade))(/(.*))$ /index.php$2
        # RedirectTemp cannot be used instead
    </IfModule>
</IfModule>

<IfModule mod_php5.c>
    # @link https://github.com/mautic/mautic/issues/1504
    php_value always_populate_raw_post_data -1
</IfModule>

One thing to note: Mautic is running in it’s own subdirectory of the web root (/mautic). All other Mautic functionality appears to be working.

Looking forward to any insights or suggestions.