User signature is ignored by webview (even though "mailer is owner" is enabled)

My Mautic version is: 2.15.1
My PHP version is: 7.2.17

My problem is: When I send a contact a “custom” email and use the {signature} token, the signature for the user logged in works just fine for the email. However, if you click on the webview link, the signature reverts to the default signature. I haven’t tested this with emails from a campaign, however. Has anyone noticed this behavior?

These errors are showing in the log: none

Steps I have tried to fix the problem: I’ve tried using various email templates as well as just sending a plain email to a number of test contacts, and the webview always reverts to the default signature.

Hi @nateifts does this happen in the latest version of Mautic? You’re running an out of date instance using 2.15.1.

I found this in Github: and maybe this one: which may be relevant.

1 Like

Hi @rcheesley. I need to update my Mautic instance…I’ve just been lazy. :flushed:
I’ll try updating and test again.

I came across one of those issue on Github (7964), but not the other. I’ll poke around there, too.


Update at command line if you can! :slight_smile: Let us know how you get on!

@rcheesley, if I update to 2.15.3 from 2.15.1, from the update now button on the notification bell, will it override any data in the current instance?

It is not recommended to update via the UI if you are on shared hosting or have any sizeable instance, as it may well result in timeouts. Updating at command line is recommended, after a full database/filesystem backup has been made.

See step by step instructions here: