Why is Mautic so difficult to install?

Sorry if this topic is in the wrong group!

I’ve been trying for 3 weeks and I could see that several people are going through the same problems and they can’t solve it!

Would it be possible to create an environment validation script before starting the installation? This script could list all the problems found at the level of environment, versions of Database, PHP and others and generate a complete log, thus, it would be easier to correct the problems of the application and help the community to drive more and more this fantastic idea !

2 Likes

Hi! its not so difficult … but you need to know something about linux . There are a lot of pages with a step by step manual , you should search that maybe. If not , hire someone who can help you the first time and explain to you (if not , use docker)

1 Like

Agree.

Mautic is a total PITA regarding installation. I installed this on a Webfaction site (twice), & on a CPanel site (3x).

I thought the first Webfaction install - manual - was fine until I tested cron jobs. I get an error, and I cannot find any solution to it. Mutliple searches + my support post has not got any replies. I tried a repeat install in a second folder - and got the identical cron errors …

I then tried installing on Cpanel - and tried to upgrade from 3.02 to 3.1 - only for it to stall each time I tried to upgrade.

I contrast this to the simple 1 minute install of WordPress (& now auto update of plugins - which is working well).

Mautic has lot of promise, but it is way to fragile when it comes to installation and upgrades. I want to be able to focus on personal use + offering marketing services to clients, not debugging code each time there is an update…

Disappointed …

2 Likes

if you have Cpanel, install through softaculous. Works well. Also go into app/config local.php and change the mysql driver from “mysqli” to “pdo_mysql”. Seems to be more reliable.

Hi
Tried that - still doesn’t run the update.

I have been on Webfaction (my son’s influence) - and on that hosting I did a manual install via SSH. No issues with getting it set up, but when I try running the cron jobs, I get the following error:

Parse error: syntax error, unexpected ‘->’ (T_OBJECT_OPERATOR) in /home/jeffw/webapps/mautic/vendor/tightenco/collect/src/Collect/Support/Collection.php on line 103

Tried looking at the code (I was writing PHP-based plugins for WP as far back as 2005 - so diving into code is not unfamiliar) - but really want to focus on using the platform for marketing - not going back down into debugging coding. That’s no longer fun for me.

Last resort will be to ditch Webfaction & try a Mautic-friendly hosting.

1 Like

I’m replying here as I can’t figure out how to start a new topic.

I’m a newcomer and not that knowledgeable. I recently downloaded Mautic but can’t work out how to get to the next stage of the installation process (the onscreen installation using a browser). I’ve tried typing the following into Chrome, Safari and Firefox:

http://[website domain]/7_mautic-401
/var/www/[website domain]/7_mautic-401

Is there something obvious that I’ve missed? Many thanks in advance.

Hi,
There are MANY install Mautic videos on the web and they all address this issue.
Just a couple:

Here is a blogpost with installing instructions step by step if you use ssh:

1 Like

if only one of them had a Docker complete guide I would be so glad.

Why docker? :wink:

1 Like

Maybe they may want to run the application on NAS or raid array?

1 Like

if I dont get this one on docker, i will just delete my portainer and install wordpress, nginx, ssl and mautic on the instance with only ssh…

Or just on another VPS.

1 Like

but my IP is already being used for my domain

Install Mautic on a subdomain :slight_smile:

1 Like

i keep getting this error after installing certbot:

E: The repository ‘Index of /certbot/certbot/ubuntu jammy Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I noticed your tutorial installs apache2, which I already have… I am zero for coding, as you can see… that is why I followed the docker ones that come with a yml ready to use…

thanks anyway…

Ubuntu 18?
My tutorial is still valid. I’m an apache guy, yes. If you follow my tutorial on a vps, it should be okay.

lol…
I’m using ubuntu 22, Apache2.
I installed the packs anyway, just in case…
The error on certbot, do you think It is the ubuntu version?

Seems to me that you have an incomplete certbot install. But I might be wrong. Try to remove and re-add.

1 Like

Hi I managed to install it on a separate server! Using your tutorial, many thanks.
Now the real trick was to set up a subdomain on the first server with docker container, I will put you on my list of torturers. :slight_smile:

1 Like

Hello everyone…

Im trying to install Mautic 3 or 4 but each time I upload files and each time is missing ‘installation’ folder so each time im going to website with uploaded files index.php/installation is missing

could anyone help me with this pls