Mautic Community Forums

WordPress Pages with Muatic are Slow

Hi everyone



I have Mautic and the WordPress website in question running on the same dedicated server. Server load is very good with no spikes.



WordPress Environment:

Latest Version of WordPress

WP Fastest Cache



The problem:

  1. On any WordPress page with a Mautic form, the page loads rather slowly, in the browser info bar it always shows the site is waiting for the mautic install URL (www.mautic-install-address.com)
  2. When completing a form it takes quite a while for the form to be submitted.



    Any ideas on where to start addressing this?



    Thanks in advance.

Hi everyone

I have Mautic and the WordPress website in question running on the same dedicated server. Server load is very good with no spikes.

WordPress Environment:
Latest Version of WordPress
WP Fastest Cache

The problem:

  1. On any WordPress page with a Mautic form, the page loads rather slowly, in the browser info bar it always shows the site is waiting for the mautic install URL (www.mautic-install-address.com)
  2. When completing a form it takes quite a while for the form to be submitted.

Any ideas on where to start addressing this?

Thanks in advance.

Make sure you’ve excluded the Mautic tracking pixel (mtracking.gif) from the cache.
The pixel should be served up to each visitor in order to cookie and track each contacts’ activity individually.

Hi autoize

Thank you for the reply.

Ok I have the WP Mautic plugin installed so when checking the page source I don’t see the mtracking.gif. Am I misunderstanding or how would I proceed?

Many thanks.

Ok what seems to have worked in speeding up the pages with Mautic forms on (I’ll test and see and advise if anything changes) was to simply copy the entire script that I found when viewing the page source, and then adding an exclusion in WP Fastest Cache’s settings which includes and “Excludes” tab in the settings.

Any other feedback though, will be appreciated so please do comment.

And what is the hardware of the “dedicate server”

Hi ninjoan

Specs are Xeon Quad-Core, 8GB RAM, RAID 1 1TB and 100mbps network.

have you check the servers process tab if the system is big you will see a lot of CPU use especially for mysql