Mautic Community Forums

2.11.0 Released!

We’re happy to announce that our 2.11.0 beta period is finished and the full version has been released! Read the full release notes here.



If upgrading from earlier than 2.6.0:

If you are have access to SSH, we highly recommend that you use the update script. Download it to the root of your Mautic installation and run it from SSH/CLI with php upgrade.php. If you are on a VPS, be aware of the user used to execute that command as you may have to fix the owner to be that of your web user. Be sure to remove this file once the upgrade is complete.



update_available.png



Click Update Now and follow the prompts.



If you have any issues - be sure to checkout John’s post.



Happy Marketing!



The Mautic Team

We’re happy to announce that our 2.11.0 beta period is finished and the full version has been released! Read the full release notes here.

If upgrading from earlier than 2.6.0:
If you are have access to SSH, we highly recommend that you use the update script. Download it to the root of your Mautic installation and run it from SSH/CLI with php upgrade.php. If you are on a VPS, be aware of the user used to execute that command as you may have to fix the owner to be that of your web user. Be sure to remove this file once the upgrade is complete.

Click Update Now and follow the prompts.

If you have any issues - be sure to checkout John’s post.

Happy Marketing!

The Mautic Team

So when I click on the notice, I see a screen that say downloading… then “Package could not be found!”

What package is it looking for and where do I find it?
Is it looking for the zip file from github? Or is there a separate update file somewhere? If so, do I just upload the zip file? Do I then extract the zipped files into the home directory and rerun the notice?

Same error as with the last upgrade from CLI -

php upgrade.php 
Checking for new updates...updating to 2.11.0!
Extracting the update package...failed. Package could not be found!

Then used:

php app/console cache:clear
php app/console mautic:update:find
php app/console mautic:update:apply

This seems to have worked. The upgrade.php script route appears to be broken, and has been for some time now.

After the upgrade it looks like the campaign action to add a lead to another campaign seems to be functional in the UI at least - fingers crossed…

Hey @mattd, that’s great news! Thanks for checking this out and sharing…

Cheers,
Rob

mattd - Thanks! That worked.

Hi The Mautic Team

Just updated my installation via a C-Panel - No problems.

Excellent

Tnx

Jacob

Some issues that I have encountered:

  • Syncing with Zoho just died. Tried reactivating plugin, re-authorising and authenticating. Nothing is being pushed to Zoho.

  • The forms are stuck on “Please wait” again. Rebuilt cache. Did not work. Followed this fix: https://www.mautic.org/community/index.php/8154-form-is-hang-on-submit-button-after-hit-submit/p2#p25623

  • Triggers:

    • If selected “YES”: (Trigger for existing applicable contacts upon saving (if published)? Clicking “Apply” greys out the buttons: “Cancel” “Save & Close” and “Apply”. Selecting “No” causes no errors.

Hey guys, in release notes you state that feature monitor emails for reply is included in this release, yet I can’t find it anywhere in campaign builder. Is this a mistake or I’m missing something?

I’m trying to update from 2.10.0 using the the built in updater. It stalls on “Extracting Package” in progress. I’ve also tried on an older 2.8 test install with no data in it. Same issue.

I worry this won’t be so stable as I think. Should I stay at 2.10.1?


Nice to be here with you guys, let’s make a great community!
My Blog: FuSuSu.com/en/
My Best Recommend For Mautic: ElasticeMail + Vultr VPS.

https://www.mautic.org/community/index.php/8718-2-10-1-2-11-0-emails-not-sending/0 :frowning:

Are there instructions on how to make this work?

“Enable passing cookie value to Mautic when using a non Mautic form”

https://github.com/mautic/mautic/issues/4775

encountered this error while upgrading from 2.10 to 2.11.0

https://www.screencast.com/t/sqXha6JwWNE

here is the log

https://docs.google.com/document/d/170m3Pt6fGraPobAhIr-jlopull6xAPNmT8Ub7z2qGUw/edit?usp=sharing