4.2.0 Email Editor Bug

Your software
My Mautic version is: 4.2.0
My PHP version is: 7.4
My Database type and version is:

Your problem
My problem is:

When you go and edit an email, open the builder and open code editor - works, close the builder, go back and open the editor and click code mode, module does not show up again

These errors are showing in the log:

Steps I have tried to fix the problem:

1 Like

@adiux I think this was one of the bugs which was addressed in the release? Maybe an asset generation issue?

@mikew are there any errors in the console (developer tools) or logs?

I was so excited to see us past this bug, so have installed on two separate instances.
Not seeing anything in mautic.error log and nothing in console

@mikew how are you installing, with the zip installer or with Composer / Git?

If the latter have you tried running bin/console m:a:g?

Could it be a cache issue? Did you already try incognito mode?

@rcheesley I am installing with command console mautic:update:apply

@adiux I have just tried in incognito mode as well and same behaviour

OK thanks for the feedback!

Same issue, here
Same configurations,
in my case I disabled the Graph JS
then I go and try to create new email, while the text potion of template loads the images take forever and no further progress is possible.


I have the same issue, with same configurations.


Can you plz check if your HTML has not intended code pieces?
Go to database
→ emails table
→ custom_html column
check the content.
Are there any NULL at random places in the html code?

hello, I did not find the topic I needed, but I see that in this community there are those who are well versed in this topic. I am interested in encrypted mail, I recently encountered the need for encrypted emails and files to be sent. Searching the Internet, I found one of these beeble.com, in principle, I am completely satisfied, I like that it is possible to send not only encrypted letters and files to traditional mail, but also send audio and video, and there is a function of self-destructing letters. But I would like to get acquainted with all such options or learn more about this beeble.

Hello @joeyk,

For me on database don’t have any “NULL” information.


I’m working on the issue that the code editor is not reopening after closing the builder. I already had a fix, but it did break something else. So I have to dig deeper. Maybe change the whole code editor popup implementation.
The workaround in the meantime: refresh your browser window.