403 Forbidden error on WAMP

Your software mautic 4.4.2
My PHP version is :7.4.26 - but have also tried 8.0.13 and 8.1.0
*My MySQL version is: MySQL 5.7.36

Updating/Installing Errors
*I am: Installing
installing via : windows chrome

These errors are showing in the installer : It doesn’t get that far: 403 Forbidden error

These errors are showing in the Mautic log : No log is produced that I can find

Your problem
My problem is :slight_smile:
I have a wamp installation on my PC for developing and testing stuff. I can load wordpress just fine and works like a charm. However, if I create a directory below ‘www’ for a new domain and put all the unzipped files from the latest mautic download into it, I get 403 Forbidden error. if I remove those files and put newly unzipped wordpress files in the same directory, Wordpress install opens normally. If I remove all the wordpress files and put back the mautic files and directories, including the .htaccess that comes with mautic, I get 403 forbidden again.

I’ve previously successfully installed mautic on a live site, hosted by Rochen, in a subdirectory, without doing anything that I can recollect to any configuration files. I’ve checked conventional windows file and folder authorities on the main directory and index.php from mautic and index.php from wordpress and they appear to be exactly the same as each other when comparing different categories of user. I have searched all the forum entries for WAMP, but none seem to have had quite the same problem which is that it won’t even seem to run the index.php file from a fresh file copy. I’m an experienced programmer and have run several Joomla sites, but have relatively little experience at messing with web-related configuration files so I don’t know where to look. There are no log files produced within the directory that mautic is in.

The access log has an entry when I try to go to index.php: ::1 - - [17/Sep/2022:09:03:47 +0100] “GET /pivotalshift.co.uk/ HTTP/1.1” 403 284

The apache_error log has an entry: [Sat Sep 17 09:03:47.037964 2022] [authz_core:error] [pid 9492:tid 1204] [client ::1:50223] AH01630: client denied by server configuration: C:/wamp64/www/pivotalshift.co.uk/index.php

So I’m really puzzled as to why index.php from wordpress works fine, but index.php from mautic doesn’t seem to be allowed, when the authorities on the two files appear to be identical. Can anyone shed any light on this?

Thanks
Mike Hersee

Why not use ddev to develop mautic locally? Its all configured for you, install docker move to mautic directory and run ddev start

Its not exactly answer to your question, but it seems to be straight forward solution.

Hi, I wasn’t even aware of ddev, but I am familiar with WAMP and it’s worked perfectly fine and predictably in the past for both Wordpress and Joomla. My understanding is that it’s a good representation of a hosted server environment and therefore it should work properly. I’ll take a look at ddev, but I can’t help feeling that the answer is probably something fairly simple. I also feel that I should understand why it isn’t working in WAMP in case I unwittingly encounter the same issue again in a live environment.

Thanks for the suggestion though, I’ll take a look at ddev.

Ok, I took a look at ddev, and I saw that you need to load docker, so I took a look at that. I see there’s a one-hour docker tutorial and got a bit of a grasp of it from watching a 15-minute introduction. This is feeling like layers of complicationa and new things to learn, so it’s not feeling like the kind of solution I’m after, when there surely must be some simple reason why mautic install is forbidden on WAMP when wordpress works fine. But thanks for the suggestion.

You do not actually need to know docker, I think when your focus is running mautic.

Without looking into server config its really hard to provide solution to your original question.