503 in Console when saving contact details

Your software
My Mautic version is: v4.4.9
My PHP version is: 8.0.29
My Database type and version is: MariaDB 10.4.20

Your problem
My problem is: Cannot update/save contact details. I get a 503 console error. No log errors display. Here’s a screenshot of what occurs when I try to edit/update any fields and click to save:

These errors are showing in the log:

Steps I have tried to fix the problem:

I have seen this error with 4.4.9, recent installation, by saving emails, if you have a solution, plz share, I’ll do the same thing.

I am curious to know if you have installed and activated the hubspot plugin? I encountered similar issues right after trying to set up that plugin. Maybe just co-incidence

Not using hubspot.

Recently updated to 4.4.9, but also new to Mautic.

probably not related but have you checked the permissions on the directory, try and chown the entire mautic directory again, rm var/cache/ as well. if you have access to the server and can tail -f /var/log/nginx(orapache2)/mautic.* to see what happens when you save

Did all of that. Still no changes.

What’s also weird is the API is returning 503 errors.

[errors] => Array
[0] => Array
[code] => 503
[message] => The response has unexpected status code (503).


503 Service Unavailable

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Apache/2.4.57 (Debian) Server at mautic.(removed-4-security).com Port 80



I am a developer in Gauchoplugins.

I tried to reproduce the error locally and got the following error log:

[Fri Jul 14 22:19:19.923378 2023] [php7:error] [pid 122564] [client] 
PHP Fatal error:  Allowed memory size of 2122317824 bytes exhausted (tried to allocate 20480 bytes) in /var/www/html/app/bundles/LeadBundle/Entity/CustomFieldEntityTrait.php on line 249, 
referer: https://mautic.domain.com/s/contacts/edit/3332

PHP memory_limit was initially 128MB. I tried by increasing it upto 2024MB but got the same error. How do I debug the code which is causing OutOfMemoryException?

Somehow the issue was caused by having a Custom Field called “Imported”. After removing that field, I was able to save contact data again and use the API properly.

Even when recreating the field with the same alias “imported”, it had the same issue. Finally renaming the alias to imported1 was also OK - just the alias “imported” didn’t caused the issue. So strange!!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.