Mautic Community Forums

Ah well. I have to admit defeat. Bye bye Mautic. I certainly gave it a try!

This now makes a full week that I’ve been trying to get a vaguely working instance of Mautic. After initially installing through my CPanel, I spent days putting out a few fires with not being able to create emails, then not able to create landing pages, only to come across a seemingly insurmountable problem of not being able to create forms. I tried asking here, but no joy.

So, today, I dowloaded the source, and spent all this afternoon and evening uploading it to my server. I created the database, and successfully got through the initial stages of creating user and filling in e-mail transport details. Now I immediately have the 404 error. Something to do with default index.php and mod_rewrite, I guess. Whatever. I have to give this away. I’m not going down yet another rabbit hole. It’s a shame. I really, really wanted this to work, but the definition of insanity and all that…

Now, this is a developer of over twenty years’ experience, and I can’t get Mautic working in any fashion after a week of trying. There’s something wrong with that picture.

For my sanity, I have to delete all from my server, and look elsewhere. Maybe I’ll just have to write the functionality I need myself. Hell, I could have done quite a bit of it already in the time I’ve wasted this week.

Cmon, hit me up, I’ll help you.
Noone should be left behind :slight_smile:

3 Likes

Lol. Thanks, Joey. Well, current state is that I have three instances installed. Two have the error of not being able to create forms, but I found a bug report and a possible workaround for that on Github here.

For the new installation, I can only get to a log in page if I put index.php into the url which it redirects me to. I can’t log in, though, because it then redirects upon login to another page which needs “index.php” being inserted. Sounds like a mod_rewrite thing.

Sent you PM. I’ll try to troubleshoot it for you.

2 Likes

Love to hear how this plays out :slight_smile:

agree totally with @joeyk. The community is really great here.

This is a fail safe way to install Mautic and get it running: https://www.linuxbabe.com/ubuntu/install-mautic-self-hosted-email-marketing-platform-ubuntu-18-04

This is tested for Mautic 2.16.x. For Mautic 3 there are different versions of mysql/mariabd that you will have to use and IMO Mautic 3.x is still not ready for full production (sorry to everyone that disagrees, but I have played a lot with it and have multiple clients running Mautic and I am just not there in terms of confidence in moving them over just yet - I do use it for my own operation)

Good luck with the tutorial. I would also stay away from hosted solution and go spend $5 on digital ocean and get your own server. Use my link of you do signup : https://m.do.co/c/1443f9d1d3f4 and you will get $100 free credit to be used in the first two months.

Well, I had another look at the instance that I had uploaded from the source. Upon checking, there was no .htaccess file. I uploaded that .htaccess, and I seem to have a working instance of Mautic!

I’m still running through the config, and setting up some things, but I haven’t come across an issue yet! I’ve even been able to create forms.

3 Likes

I should have done this much sooner, but I would like to thank @joeyk very much for taking time out of his day to go over some of the features of Mautic with me via Skype. That was very generous, and kind of you! It was very much appreciated.

2 Likes

I have done this so many times (copy up without realising I missed the .htaccess) … it’s such an easy one to miss!

Glad you got it sorted, and I echo your thanks to @joeyk for helping with the issues you were facing - we have some awesome community members!

4 Likes